x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Playercontroller not working

Posting this in Packaging & Deployment since i'm not sure where else to put it (using UE4?), let's start.

Hi,

I started out with a blank c++ project (either on 4.1 or a 4.2 preview from github), using mainly blueprints. Until a few (3 maybe) days ago nothing was wrong everything was working, even when packaged.

Since then i've changed a few things, in c++,blueprints and i added a menu using UMG.

Now when in editor, when i use selected viewport or new editor window to test, everything still works, but when using standalone game or the packaged version it seemed like the playercontroller wasn't receiving any input.

The pawn was working with input, so i tried triggering events in the playercontroller from the pawn, yet this didn't change anything. Both new editor window and standalone game use the correct playercontroller class, so that's not the problem. I disconnected everything in the playercontroller's blueprint and only had BeginPlay linked to print string ("Hello"), this did work in new editor window, and not standalone game.

Does anyone know why this happens and/or how to fix this? Should you need more information, feel free to ask.

Thanks, Thommie

Product Version: Not Selected
Tags:
more ▼

asked Jun 16 '14 at 07:24 PM in Packaging & Deployment

avatar image

Thommie
71 3 6 8

avatar image Thommie Jun 17 '14 at 03:41 PM

Forgot to mention, i started on 4.1 or 4.2 preview, but currently i'm working with default 4.2 with -umg.

Did some more experimenting today, created a new playercontroller in blueprint, extending the previous one and this one does work. I'm lost.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hello,

Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes. If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, could you please submit a new report for it.

Thanks!

more ▼

answered Nov 25 '14 at 05:06 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.9k 292 13 76

(comments are locked)
10|2000 characters needed characters left

So apparently using my umg hud was the problem, i moved everything in the playercontroller referencing my hud (extending userwidget) to another class and suddenly it worked again, seems i have to wait for a new release to get the menu to work.

more ▼

answered Jun 17 '14 at 04:13 PM

avatar image

Thommie
71 3 6 8

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question