x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Event BeginPlay Node Not Working?

Hi, Today I launched UE 4.15 to work on my game which I was very excited about and to my disappointment nothing worked like it used to yesterday when I saved and quit the engine, so I thought to my self what could be causing the widgets to fail the cast leaving the variables null. So I looked at the level bp which spawns my main menu widget and this is what I found. The Event BeginPlay node was clearly not working because It wasn't spawning the widget so I tried plugging the Use Button (E) To see if that could trigger the widget to spawn and It did. I don't really what could of caused this as everything worked perfectly yesterday, but for now until I get an answer I can't do anything :/

Best Regards, NijoMeister

Product Version: UE 4.15
Tags:
fixpls.png (100.9 kB)
more ▼

asked Mar 06 '17 at 04:55 PM in Blueprint Scripting

avatar image

NijoMeister
70 9 10 16

avatar image Thomas G ♦♦ STAFF Mar 06 '17 at 05:40 PM

Hello NijoMeister,

I was not able to reproduce your issue on our end. I have a couple of questions that will help me narrow down your issue.

  1. Can you reproduce this issue in a new project?

  2. If so could you provide a detailed list of steps so I can reproduce this issue on our end?

  3. Are you using a custom GameState or GameMode in your project?

avatar image NijoMeister Mar 06 '17 at 06:08 PM

Hi, Thomas thanks for the answer! Hope this helps :)

  1. I can't :p Everything seems to be working fine.

  • Can't answer because I don't really know what happen and yesterday everything was fine.

  1. I'm only using a custom Game Instance, But even when I change it to default it doesn't work.

Best Regards, NijoMeister

avatar image Thomas G ♦♦ STAFF Mar 06 '17 at 08:51 PM

Would you be willing to send me your project so I can look into your issue further? You can private message it to me on the forums via this link here:

https://forums.unrealengine.com/member.php?680446-ThomasVanZeeland

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Thomas I'm so sorry for taking up your time but I really didn't know that my GameState changed so just by changing it back everything started working :p Anyway thank you :)

Best Regards, NijoMeister

more ▼

answered Mar 06 '17 at 08:54 PM

avatar image

NijoMeister
70 9 10 16

avatar image Thomas G ♦♦ STAFF Mar 06 '17 at 09:23 PM

Glad to know things are working for you now!

Good luck on your project!!

avatar image NijoMeister Mar 06 '17 at 09:52 PM

Thanks a lot :) I will let you know when I'm done :)

Best Regards, NijoMeister

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question