x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to fix: Could not find code error

I just downloaded unreal engine on to 2 of my machines. I wanted to try out writing a plugin so I found a live stream video where the programmer shows the widget reflector. When I click a code file it says "failed to find code file: whateverdirectoryishere." The directory is nonsense and is pointing to a thumb drive. I have this exact issue on both computers. I tried reinstalling on one machine and it did nothing. I can navigate the source code manually inside visual studio but the widget reflector is linking somewhere else.

How can I change the directory the widget reflector is looking for the source code in?

Product Version: UE 4.15
Tags:
more ▼

asked Mar 07 '17 at 04:09 AM in Installation & Setup

avatar image

Rhombuster
6 1 2 3

avatar image Matthew J Mar 07 '17 at 10:04 PM

Hello Rhombuster,

Did you download your engine from the Epic Games Launcher or did you download the source code from Github and build it? Does this happen with every code file you try to click on? What widget did you select? Can you provide a screenshot of this occurring?

avatar image Rhombuster Mar 07 '17 at 10:28 PM

Hello,

I downloaded the engine from the launcher. I installed the editor to the C drive. I already had visual studio 2015 installed.

I can open cpp files from the content browser (like example project files). But every link inside the widget reflector is broken. This exact thing is happening on 2 separate machines that downloaded independently. They both ask to access D drive.

Originally I thought it was because my project file was on a flash drive. But I uninstalled, wiped project files, cleared AppData of anything unreal related. Uninstalled the unreal launcher. Downloaded all of it again. The exact same issue has come up.

alt text

screenshot.png (609.9 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I run into the same problem and I think this function only works if you had build the engine from source because the path you get is the same I get and it seems to be the original build path the engine was built at Epic and its somehow hardwired into the code.

It is annoying that you even can't copy the path and I found no other solution to this then to remember the file name and manually open it.

more ▼

answered Mar 07 '17 at 10:48 PM

avatar image

SteffM
432 12 4 22

avatar image Matthew J Mar 08 '17 at 08:17 PM

Good catch, SteffM. It seems the reason it works in Binary for me is due to it actually accessing the file from my source build. As this is a developer tool, I wouldn't expect full functionality from it in a Binary build so I would suggest using a Source build if you need to use this.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question