x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Smoothing groups fbx import bug

My team keeps getting:

"Warning No smoothing group information was found in this FBX scene. Please make sure to enable the 'Export Smoothing Groups' option in the FBX Exporter plug-in before exporting the file. Even for tools that don't support smoothing groups, the FBX Exporter will generate appropriate smoothing data at export-time so that correct vertex normals can be inferred while importing."

However, we're exporting the smoothing groups correctly from 3ds Max and we've verified the smoothing groups are importing correctly by importing 2 versions (1 with and 1 without). alt text

Seems like people have been having this issue for a while now, so is there anyway Epic could take a look into this?

Product Version: UE 4.15
Tags:
more ▼

asked Mar 07 '17 at 07:38 PM in Using UE4

avatar image

Cirralisis
36 3 5 5

avatar image Matt.Williams Mar 17 '17 at 06:57 PM

Hey Cirralisis,

Just to be clear, you're exporting with smoothing groups disabled, but when you import, the smoothing groups still appear to work on import (even with the error)?

I'm having some trouble reproducing this on my end. Could you perhaps provide your max file?

-Matt W.

avatar image Cirralisis Mar 17 '17 at 10:30 PM

Hey Matt, Not quite. Our test here was with 2 fbx files. One exported with smoothing groups, one without. So, clearly the smoothing groups are being "found" and imported correctly.... just wondering if you're planning on removing this false warning?

avatar image Matt.Williams Mar 24 '17 at 03:04 PM

That's the issue though, they SHOULDN'T be found and imported correctly with "Export Smoothing Groups" disabled. I'm trying to figure out if this is an issue with the fbx exporter or with the engine.

What version of Max are you using? Which FBX version are you using as well?

avatar image Cirralisis Mar 28 '17 at 05:22 PM

So we're using the 2014 version of Max with FBX 2014 binary assets.

But let me rephrase, because there's still confusion: We created 2 FBX files in Max. With_Smoothing_Groups.fbx and Without_Smoothing_Groups.fbx. We only selected "Export Smoothing Groups" in "With_Smoothing_Groups"

Then we imported both into Unreal.

Without_Smoothing_Groups gave us the error, and as you can see in the image, there are no smoothing groups.

With_Smoothing_Groups also gave us the error, but then it's still obvious that it was found and applied by looking at the mesh.

So the issue is that we're getting the error message even though the smoothing groups were imported correctly.

You can pick any random tutorial off youtube and see this bug replicated when they try to import any mesh.

avatar image Matt.Williams Mar 30 '17 at 07:14 PM

Well, looks like the Answerhub ate my comment on this thread.

Anyways, thanks for the clarification. Now that I have a better grasp on the issue, I've been unable to reproduce it on my end when exporting with smoothing groups enabled. I've tried with 3dsMax 2014, 2015, and 2016.

Can you send me your fbx and max files, by chance? You can attach here in a zip file or PM me a download link on the forums.

-Matt W.

avatar image Cirralisis Mar 31 '17 at 02:11 AM
avatar image Cirralisis Mar 31 '17 at 08:29 PM
sg_examples.zip (26.6 kB)
avatar image Matt.Williams Apr 04 '17 at 04:42 PM

Well, I definitely get it with your fbx files, but I cannot reproduce this when I manually export from your max scene with 3ds Max 2014 (which is what I need to be able to do to enter a bug report).

Can you take screenshots of your entire export and import settings from Max and Unreal, respectively? Please make sure to expand all fields.

avatar image Cirralisis Apr 07 '17 at 05:15 PM

alt text

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Cirralisis,

You get this warning when exporting with "Split per-vertex Normals":

alt text

Reading it, it shows that with "Split per-vertex Normals" enabled, "Hard edges and smoothing groups are also lost". Please disable "Split per-vertex Normals" if you want to export smoothing groups.

-Matt W.

more ▼

answered Apr 13 '17 at 06:25 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question