x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to stop UE4 editor auto-starting SteamVR?

Hey guys, quick question here. I have a HTC Vive connected to my PC and whenever I start up the UE4 editor, SteamVR also starts up. Any way to stop the launcher and editor to do that?

I've already tried the following:

  • Disabled all VR plugins within the editor and restarted the editor

  • Disabled VR editor mode and auto-start VR editor mode

  • Tried to disable "Automatically start SteamVR with application" under the developer settings, however, while SteamVR doesn't run, the HMD still lights up/turns on.

Anything else I've missed? Would love to find a solution to this.

Product Version: UE 4.15
Tags:
more ▼

asked Mar 08 '17 at 12:01 AM in VR

avatar image

a2uinteractive
36 1 3 4

avatar image nic-hartley Jul 11 '17 at 01:19 PM

As far as I can tell, the only answer is "hahahahahahaha". There doesn't seem to be any setting or way to do this, short of flat-out uninstalling SteamVR (which, obviously, is not a solution. It's like curing someone's cough by shooting them.) This is a massive oversight, and badly needs to be fixed. I'm honestly shocked that it hasn't already been.

For me, it's a problem because SteamVR doesn't automatically, on an application startup, redirect sound made by that VR app to the VR headset. Sure, that's shitty coding or design on SteamVR's part, but they at least have a very easy workaround: You can have SteamVR, on startup, redirect all your computer's sound to the VR headset. (This may even be the default; I could well have changed the setting at some point.) Now, normally, this is fine -- after all, I only start SteamVR shortly before, you know, playing VR. Then I started toying with Unreal, and before they brought up any project menu, before any settings were displayed, before any interaction short of using Task Manager or sigkill to end the process was possible, it started booting SteamVR. Invisibly. I'll let everyone reading this figure out for themselves precisely why this is not a good thing. (Hint: If your sound is redirected somewhere else, what do you hear on the old output?)

Long story short, it's a massive oversight in UE4 that somehow managed to be allowed into the final product. There's no workaround aside from manually fixing the issue every single time.

avatar image Zectbumo54 Apr 09 '18 at 06:17 AM

@nic-hartley cool story bro. Answer is below and this is duplicate of #441149

avatar image ipaulpro Dec 26 '18 at 02:20 PM

@Zectbumo54 cool story, bro. None of those answers actually disable SteamVR from running when Steam starts. Having to manually edit the .unplugin file every time you update is hardly a solution.

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Hello to disable SteamVR at the launch of unreal engine I did like this: open the file with a text editor :

C:\Program Files\Epic Games\"Engine Version"\Engine\Plugins\Runtime\Steam\SteamVR\SteamVR.uplugin

modify the line : "EnabledByDefault" : true,

with : "EnabledByDefault" : false,

save the file

The SteamVR plugin will no longer launch with the engine.

PS : sorry for my bad english, i used google translate.

more ▼

answered Jan 30 '18 at 01:53 PM

avatar image

Yaerith
126 1 5 3

avatar image Pedro_Cubano Mar 22 '18 at 10:06 PM

Thats the only one that worked for me, thanks!

avatar image schmoudi.moudi Jul 30 '18 at 02:26 PM

Thanks a lot! This also works for the Oculus startup in the OculusVR.uplugin file

avatar image Corncutter Nov 21 '18 at 08:37 PM

Thanks. It got really annoying since I'm currently setting up a Windows Mixed Reality project and when SteamVR is running it always detects the HMD as SteamVR instead of the WMR one and therefore messes up all the controller inputs. This helps a lot.

avatar image Anaxares Dec 02 '18 at 11:50 AM

Works perfect, after having tried other suggestions without success.

avatar image sebaenam 5 days ago

Why this isn't marked as solution? Thanks man! I hate that popup

(comments are locked)
10|2000 characters needed characters left

Open the edit tab at the top of your screen. Click on Plugins. In the left pane of the window scroll down to Virtual Reality and click on it. In the right pane scroll down and uncheck SteamVR. You have to do it every time you make a new project.

more ▼

answered Jul 15 '17 at 01:18 AM

avatar image

cannibalisticwalrus
41 3 5

avatar image Onitz Jul 15 '17 at 01:24 AM

The Hero we need

avatar image nic-hartley Jul 16 '17 at 08:58 PM

I don't know about anyone else, but this doesn't work for me. At all. Because it's not opening the project that boots SteamVR, it's clicking "Launch" in the Unreal launcher -- that is, while it's opening the window with the title "Unreal Project Browser", it turns SteamVR on. This does not fix that; yes, I've tried it, and it still doesn't work.

avatar image a2uinteractive Jul 17 '17 at 10:59 PM

You're not alone, I have the exact same issue and as I've described in my initial question, I've already tried to deactivate all VR related plugins but this doesn't change this behavior, unfortunately.

avatar image dlam26 Dec 11 '17 at 08:25 AM

@nic-hartley dosent work for me either on 4.17.1

(comments are locked)
10|2000 characters needed characters left

The continual popup is absolute cancer. I don't even have a VR device.. After dicking around in the popup settings, project settings, the only reprieve i got was from deleting everything with the name steamvr under /Epic games in program files. Fingeres crossed it persists between restarts, this has been a disheartening intro to an otherwise promising engine

Edit: Repairing my install and using cannibalisticwalrus' answer was a much better approach

more ▼

answered Jul 15 '17 at 01:07 AM

avatar image

Onitz
6 1 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question