x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Linux UE4 Editor -- Gizmos painting screen black

I'm running UE4 4.15 in Arch Linux, running a Nvidia GeForce 730M video card and the open-source nouveau video drivers (the proprietary ones don't work with my system, giving me a black screen on boot). Unreal compiled and opened fine, provided I use the -opengl3 parameter.

If the editor is run using the default parameters or -opengl4, it crashes with the following message:

[2017.03.08-03.52.49:553][ 0]LogInit:Error: _PlatformCreateOpenGLContextCore - Could not create OpenGL 4.3 context, SDL error: 'Could not create GL context: GLXBadFBConfig' [2017.03.08-03.52.49:553][ 0]LogRHI:Error: OpenGL 4.3 not supported by driver

However, when a project is opened under opengl3, the gizmos start "painting" the screen black. It feels a lot like in the old Windows XP days, where when something stopped responding, you could drag it around and "paint" the screen with it. Here's a few screenshots of it happening:

Start

Slow corruption

Almost black

Black

As you can see, the more I move the screen around, the blacker the screen gets (due to the gizmos). Has anyone else had the problem? Is there any fix for this?

Product Version: UE 4.15
Tags:
more ▼

asked Mar 08 '17 at 04:13 AM in Linux

avatar image

Jay2645
183 4 11 23

avatar image raigfp Apr 18 '17 at 07:13 AM

I move the screen around, the blacker the screen gets (due to the gizmos)

Same rendering problem, but no difference: with default parameters or -opengl3 or -opengl4 (without crashes)

Ubuntu 16.04

 $ glxinfo | grep "OpenGL"
 OpenGL vendor string: Intel Open Source Technology Center
 OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 520 (Skylake GT2) 
 OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.0.3 - padoka PPA

UE from release branch, this commit: https://github.com/EpicGames/UnrealEngine/commit/f44f8e5a6237f9e498f592ddceaa23ad90858675

avatar image DmitriF Apr 25 '17 at 07:36 AM

Same problem Ubuntu 16.04.2 LTS with intel hd graphics

no matters -opengl3 or -opengl4, without crashes

 glxinfo | grep "OpenGL"
 
 OpenGL vendor string: Intel Open Source Technology Center
 OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 520 (Skylake GT2)
 OpenGL core profile version string: 4.3 (Core Profile) Mesa 12.0.6
 OpenGL core profile shading language version string: 4.30
 OpenGL core profile context flags: (none)
 OpenGL core profile profile mask: core profile
 OpenGL core profile extensions:
 OpenGL version string: 3.0 Mesa 12.0.6
 OpenGL shading language version string: 1.30
 OpenGL context flags: (none)
 OpenGL extensions:
 OpenGL ES profile version string: OpenGL ES 3.1 Mesa 12.0.6
 OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10


avatar image C. Mitch Carroll Apr 26 '17 at 04:12 PM

I have the same problem on Arch Linux, integrated Intel HD graphics card. I have tried all of the -opengl flags, and have attempted the fix above, but nothing works. This behavior occurs on every linux machine I have tried it on. It makes the entire editor basically unuseable. The only thing that helps, short of quitting and restarting the editor is switching to wireframe view, and then back to whatever I was trying to use before. I can't give a lot more info because this bug has made it basically impossible for me to learn to use the editor in the first place.

avatar image Blunt Arrow Apr 27 '17 at 05:11 AM

Same problem on Arch Linux gnome desktop GTX 1060

(comments are locked)
10|2000 characters needed characters left

7 answers: sort voted first

For anyone else visiting this from the future (be sure to tell the robot overlords I said hello!): I figured out a workaround. In the viewport, go to Show and click Show->Sprites->Hide All, then uncheck Show->Grid.

This will hide all the sprites in the editor, but will also turn "off" all the blackness.

I'd prefer an actual answer to the question, but this works for now.

more ▼

answered Mar 08 '17 at 05:12 PM

avatar image

Jay2645
183 4 11 23

avatar image n_goncharuk Mar 12 '17 at 06:54 PM

Same problem on Fedora 25 and intel hd graphics 4600. And this workaround don't help.

(comments are locked)
10|2000 characters needed characters left

Hi,

I have this issue on Ubuntu 17.04 too, but have found that if you enter full-screen mode, shift-f11, this is a feasible workaround.

The only other thing that I have done today is to upgrade mesa to 17.1.0-rc2 and I still have the same issue when not in full-screen.

Try it and I hope it works for you.

Cheers, Mark

P.S. Sorry for multiple answers, but I am not seeing the updates (if any!)

more ▼

answered May 03 '17 at 01:30 PM

avatar image

marpate1
6 1 1

avatar image GNUton May 05 '17 at 02:54 PM

That has worked for me! Thanks here my config:

Unreal Version: 4.15.2-0+++UE4+Release-4.15 Ubuntu 16.04.2 LTS GL_RENDERER: Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2) GL_VERSION: 4.3 (Core Profile) Mesa 12.0.6

(comments are locked)
10|2000 characters needed characters left

Unfortunately full screen didn't help :(

Ubuntu 16.04.2 LTS, Mesa 12.0.6 Intel(R), HD Graphics 520

more ▼

answered May 04 '17 at 07:12 AM

avatar image

DmitriF
1 1 1

avatar image marpate1 May 04 '17 at 07:39 AM

Hmm, it doesn't always work for me either.

I used to run UE4 fine on Ubuntu 16.10 back in around June last year, so maybe worth a distribution upgrade? I'm going to try installing UE4 from around that time too.

avatar image marpate1 May 04 '17 at 04:47 PM

I've just installed UE4 4.16 and the issue does not seem anywhere near as bad. Maybe try that?

There is still things left on the screen when zooming in and out, but if you select all (ctrl-a) and then escape it clears up .. so maybe try that first?

(comments are locked)
10|2000 characters needed characters left

I had this problem for a while but i managed to fix it.

Turns out my Unreal Engine was using my on board Intel APU instead of my nvidia GPU

I can now force Unreal Engine to use my GPU by running the command [ optirun ./UE4Editor ] and after this the editor works properly.

You will need the bumblebee package in order to run this command Also need to add yourself to the bumblebee group through useradd relog start/ enable the bumblebeed service Run the command to start ue4

Hope this solution works for everyone else =)

more ▼

answered May 10 '17 at 04:19 AM

avatar image

Blunt Arrow
1 1

(comments are locked)
10|2000 characters needed characters left

I had this problem for a while but i managed to fix it.

Turns out my Unreal Engine was using my on board Intel APU instead of my nvidia GPU

I can now force Unreal Engine to use my GPU by running the command [ optirun ./UE4Editor ] and after this the editor works properly.

You will need the bumblebee package in order to run this command Also need to add yourself to the bumblebee group through useradd relog start/ enable the bumblebeed service Run the command to start ue4

Hope this solution works for everyone else =)

more ▼

answered May 10 '17 at 04:19 AM

avatar image

Blunt Arrow
1 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question