x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UnrealBuildTool Failed to Compile

The UnrealBuildTool.exe is missing from "UESource\Engine\Binaries\DotNET"

http://i.imgur.com/3D0tysW.png

Product Version: Not Selected
Tags:
more ▼

asked Jun 17 '14 at 02:58 AM in Installation & Setup

avatar image

Kybe
6 2 2 5

avatar image hsrob1 Jun 20 '14 at 04:11 AM

I am running into this problem as well... Anybody?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I am currently running into that problem. Yes, it happened with the GenerateProjectFiles.bat. I have tried redownloading the dependencies, but that didn't help. I then opened up the \UnrealEngine\Engine\Source\Programs\UnrealBuildTool\UnrealBuildTool.csproj and tried to compile, and that error "Could not copy the file "obj\Debug\UnrealBuildTool.exe" because it was not found" came up. I am using the 4.3 branch.

EDIT: Solved by turning off my anti-virus.

more ▼

answered Aug 08 '14 at 07:16 PM

avatar image

DoctorWhy
93 11 12 14

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Kybe,

Did this error occur when you tried to run the GenerateProjectFiles.bat file after downloading the source code? Could you please try re-downloading the dependency files for the version you are trying to build to make sure none of those files were corrupted?

more ▼

answered Jun 20 '14 at 04:05 PM

avatar image Tim C ♦♦ STAFF Jul 10 '14 at 10:55 PM

Hi Kybe,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question