x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Reimport static mesh with "Auto Generate Collision" OFF

Hi,

I imported a new static mesh into UE with "auto generate collision" ON. Then i wanted just to reimport the static mesh with the only change being "auto generate collision" OFF. (I want to reimport it because I've already assigned all the materials to the asset and don't want to reattach the materials again).

I first tried to go into the import settings in the static mesh'es options and un-check auto generate collision: ![alt text Then I went further down in the menu to the collision rollout, where I checked "Customized Collision": alt text

Then I right clicked the asset in the content browser and chose reimport, but it reimported the asset with auto generate collision ON.

Then I went to content browser and I pressed on the import button and browsed to the static mesh that I wanted to reimport. It asked me if I wanted to overwrite it and I said yes, so it showed up the import options again and I unchecked the "auto generate collision". This time it imported it fine, but I lost the materials and had to assign them again. So you see this is not a valid solution either.

There must be a way to reimport the static mesh with auto generate collision unchecked. Thanks

Product Version: UE 4.15
Tags:
more ▼

asked Mar 09 '17 at 01:24 PM in Using UE4

avatar image

zaksi
203 10 21 25

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

This is the correct answer. Thank you.

more ▼

answered Apr 20 '19 at 11:10 PM

avatar image

graman_2018
1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question