x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why is my apex cloth too 'rigid' in Maya?

so in maya, i have a plane ( of a cape ) that im trying to turn into an apex cloth. so i extrude the plane, smooth bind it to a joint in the skeleton, and turn the cape into an apex cloth. from here i do all the painting of the values onto the cape (it can only go 0 - 1 in the paint value, even though most tutorials have any range of value for strength of the paint). then i keyframe the joint to move so i can see how the cloth moves. well, when i run the simulation the joint will move and the cloth acts very strangely.

instead of acting like the cloth should (falling with gravity, spinning when the joint rotates, etc.) it acts very rigid like jello and won't even drop with gravity. i've tried changing the settings like gravity, damping, etc (btw none of these settings save in maya. i click away, and click back onto the cloth and they've all reset) and nothing seems to fix it. even when the cloth makes contact with the ground, instead of crumpling and laying on itself, it just... disappears.

i've tried making a very basic cube and joint in maya and did all the normal steps to make a apex cloth, and it acts naturally like apex cloth would.

im not sure if its something about the pre existing mesh, but im getting very frustrated with how much maya keeps crashing when i try changing some of the cloth settings, and its getting a bit ridiculous.

any ideas?

Product Version: Not Selected
Tags:
more ▼

asked Jun 17 '14 at 07:43 AM in Everything Else

avatar image

krailyx
33 10 16 17

avatar image Lovecraft_K ♦♦ STAFF Jun 20 '14 at 02:16 PM

Hi krailyx -

I have been trying to reproduce this error with our own cloth assets and have not been able to reproduce exactly what you are describing. Would you be willing to share you asset or a test asset that has the same problem?

If they are please feel free to upload them and I will look into them.

Thank You

Eric Ketchum

avatar image krailyx Jun 20 '14 at 05:35 PM

Here's the .rar with the .fbx in it, I was getting an error message trying to upload the rar here http://www.mediafire.com/download/5b01yvw1acr3ct7/Darius.rar

In this .fbx the cape is just a plane and it's still attached to the main mesh. My process has been double clicking the faces while in Face selection, separating from the mesh, then removing all history. After that, I deleted all but 1 cape joint (i leave the 1 in the top middle), and then smooth bind the cape to that 1 remaining. From there I turn the cape into the clothing object and begin to paint it like any other apex clothing. After done painting, I'll move the root of the main skeleton around and keyframe it, and then simulate with the physx toolbar. From here on it just produces the really strange results that I've been getting.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi krailyx -

Found your issue. It is the maxDistance, to set it to higher than 1 set your Visible Range from 0 to 150(high value here), then paint an actual max distance probably fading to a smaller distance toward the characters shoulders.

Love to see it when its all done -

Eric Ketchum

more ▼

answered Jun 23 '14 at 09:03 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey krailyx -

I think I might have found your problem. Remove the bones that are in your cape section and instead use the kinematic capsules to get the rigidity there that I think you want.

Check out the Nvidia tutorial here setting up the Kinematic bodies.

Try that and let me know if that works out for you and in the meantime I will continue to reproduce-

Eric Ketchum

more ▼

answered Jun 20 '14 at 07:52 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

avatar image krailyx Jun 20 '14 at 10:31 PM

I'm unsure of what you entirely meant by removing the bones that are in the cape (I assume you just meant leave 1 joint to bind the cape to and delete the rest), and I tried making the kinematic bodies. I wasn't able to get any different results really, unless I'd gone about doing that wrong again.

Here are the quick videos I recorded of the base mesh moving, showing how the cloth reacts, being very un-cloth like.

The mesh sliding (with slight forward and backward leaning on the slides) https://www.youtube.com/watch?v=RHjcRPunAfo&feature=youtu.be

The mesh rotating https://www.youtube.com/watch?v=IStzXQewRA8&feature=youtu.be

avatar image Lovecraft_K ♦♦ STAFF Jun 23 '14 at 03:23 PM

Hey Krailyx -

Can you show me a screeshot of you painted maxDistances? From the FBX I have seen and the videos (thank you BTW, they were very helpful), I would say that you have to give your cloth more maxDistance that it can move.

Also is your cloth a separate mesh in the FBX that I have your model is one piece, if so I would separate them out.

Let me know -

Eric Ketchum

avatar image krailyx Jun 23 '14 at 08:23 PM

This is what I'm using for my max distances - http://puu.sh/9H2KZ/56edf00b3c.jpg

I've tried changing it to a couple variations, decreasing the amount of vertices that have a value of 1.00, etc, as well as even trying to make the entire thing have a value of 1.00. How can you give the cloth more maxDistance than what I've already done? I noticed in some of the apex cloth tutorials people were able to give it values way beyond 1, while the newest version can only go to 1.

I do separate the cloth/cape from the main mesh, with selecting all the faces and then going to Mesh -> Separate. Is this not the correct way or is there some other way to do it?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question