Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

non-streaming texture over 4000 MB


I am encountering a big texture streaming pool issue : my texture streaming pool is over 4000MB! It is not related to a specific map, because this warning message appears in every map of my project. Here is a screenshot of the console with the stat StreamingDetails on :

alt text

It looks like it is related to "non-streaming textures". It is clearly a bug, that is not related to the pool capacity.

It's very weird for me because I am only using sprites or little FBX models, so they should not be greedy on texture memory. It is also appearing when I open my project on another computer. (I am working on Mac here)

Does anyone has a clue for resolving this?

Product Version: UE 4.12
stat streaming.jpg (524.7 kB)
more ▼

asked Mar 10 '17 at 01:16 PM in Rendering

avatar image

86 4 6 12

avatar image VizualTek Mar 10 '17 at 10:05 PM

Did you try to open a completely new map and see if this also appears in an empty map? If this appears in every map of your project maybe somewhere you are using either very many textures or some gigantic textures. If this is the case then your empty map should be just fine.

I would also guess that this issue is not related to the FBX models themselves or it's size, because they are just combinations of vertices and UV-maps, aren't they? They have nothing to do with textures in the first place. They can have default materials and those materials use textures.

Are you using some materials/textures always or in every map? If so, then check those out and maybe you can locate the source of the problem on this way =/

avatar image Panelsofsilence Mar 11 '17 at 09:18 AM

Thanks VizualTek for your answer.

I created an empty level but the problem remains the same : alt text

However, I created a brand new project, and think I localized the issue : it's in the sprites. In my project I am using around 200 pictures, that I am presenting as paintings, through paper 2D sprites.

What is strange, is that the original .jpeg files are quite small, but once cooked by the editor, their size goes like 20 times bigger. For instance, an asset freshly imported in the "Content" folder that weights 761ko goes to 18,6Mo (!!!) in the folder "Save/Cooked/MacNoEditor/.../Content/..."

empty level.jpg (281.8 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I finally understood my issue : I was using a lot of different pictures as textures, without respecting the "power of 2" rule. So my texture were not able to be streamed, and they were asking a huge resource size. Here is a link to a related topic : https://answers.unrealengine.com/questions/549411/cant-untick-never-stream.html

So my solution is to re-import all my images as png, in a 2048x2048 square, using the alpha channel to keep the original picture ratio.

more ▼

answered Apr 01 '17 at 04:00 PM

avatar image

86 4 6 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question