x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Particle Inherit Parent Velocity only works in world space

Hello I wanted my "flamethrower" particle to get my character velocity so I added Inherit Parent Velocity with settings x=1 y=0 z=0 however it only works in World X axis and never takes any particle system rotations.

I made a little video to show. Particle rotated 90 Yaw but still getting velocity only for X world axis. Any way to fix this?

https://youtu.be/136vMJZ8gH0

Product Version: UE 4.14
Tags:
more ▼

asked Mar 10 '17 at 09:49 PM in Using UE4

Xukapy gravatar image

Xukapy
58 2 7 13

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Xukapy,

Inherit Parent Velocity only takes into consideration the amount the parent has moved any given frame. It then applies this movement to particles multiplied by the velocity scale. By using the values 1,0,0 you multiply this movement by 0 along the y and z Axis. That is why you are only seeing movement along the x axis. Try the values (1,1,1) to see if that gives better results.

Unfortunately there isn't a local space option for this module.

Let me know if that helps,

Ed

[Post Edited] Typo removed.

more ▼

answered Mar 20 '17 at 09:57 PM

Xukapy gravatar image Xukapy Mar 20 '17 at 10:16 PM

by using 1,0,0 I multiply by 0 along y and z, not X. Im not setting values 1,0,0 for no reason. I need it to inherit from only local X. "Unfortunately there isn't a local space option for this module."??? What does that mean. There is literally In World Space checkbox!?!?!?

Ed Burgess gravatar image Ed Burgess ♦♦ STAFF Mar 21 '17 at 03:20 PM

Thanks for pointing out that typo the post has been fixed to what was intended. :)

Now regarding what I mean, the Inherit Parent Velocity(IPV) module inherits what coordinate space to use from the required module. This means it is already in world space.

You can confirm this behavior yourself by changing the required module to "local-space" and then keeping the inherit parent velocity at 1,0,0. You will see that it will move along the X axis according to the parent's orientation.

You make a good point as this behavior means that the World Space check box is effectively useless. What should have been included with this module is a "local space" checkbox and this is what I am saying is unfortunate.

This appears to be a limitation of the cascade particle editor and the behavior seen is expected. Normally, I would put in a feature request but with Niagara in development I doubt it would be addressed in all honesty.

If you want to only inherit from the X axis relative to your character there is a potential workaround, but its going to take a little bit of work to set up. This assumes that your particle system is in world space.

  • First in the IPV module change your Distribution to a Vector Particle Parameter (I named the parameter Orient) here is a screen of all settings used.

alt text - In your character BP access the particle system for the flame thrower and change the vector param to update with the character's rotation. (see screenshot)

alt text

  • Depending on what axis your initial velocity is you may need to get forward vector instead of right vector.

Here is a very short example video showing it working in action.

examplevid.zip (759.4 kB)
workaround.jpg (76.8 kB)
settings.jpg (109.3 kB)
Xukapy gravatar image Xukapy Mar 21 '17 at 06:10 PM

Well, things start to make sense now. I guess we can blame it on a lack of documantaion. Big thanks for answer, sir. Have a great day

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question