x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Trasparency / alpha shows up as half-transparency?

Hello. I am using UMG to make a text box, and I have it set up to where the name box is surrounded by two "image" things in a horizontal box. The textures that surround the name box the player sees need to have transparencies to fit my design, but transparency on these textures are not working correctly. Instead of being able to see through where the alpha channel is, the opacity comes out as a black shade with like 50% transparency.

I've attached an image to describe my issue. On the right is a blank image I created to track down the problem, it has no data in it (that I know of) other than it being totally transparent, and on the other side of where it says "speaker name," is the texture I wanted to use, and you can see the same effect happens where it's supposed to be transparent.

If it matters, I am using Windows 10 and GIMP for texture editing. I've read online in some places that GIMP handles alpha channels weird, but UE4 detects it has an alpha channel and trying the same technique in paint.net yields the same result.

Oh, and I've also tried making the raw texture (png) file into a user interface material and connecting the alpha channel pin from the texture sample to the opacity mask (with a masked domain/whatever) but I end up with the same issue in the end.

The image item in UMG has all of its color/tint values set to "1."

Any help is appreciated, this issue is driving me insane. I've tried so many different things that seem to be relevant to my issue from this and other sources, but I cannot find this same issue online elsewhere.alt text

Product Version: UE 4.15
Tags:
more ▼

asked Mar 12 '17 at 09:02 PM in Using UE4

avatar image

RedShard
30 3 5 9

avatar image RedShard Mar 14 '17 at 12:44 AM

Tried exporting the image as a TGA from gimp, still no luck. What is the dealio here

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Whoa, surprise surprise, turns out the border widget my image widget was contained in had an alpha value not set to default. WHOOPSIES.................

more ▼

answered Mar 14 '17 at 04:17 AM

avatar image

RedShard
30 3 5 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question