x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Permanent black screen after trying to use Loading Splash Screen

I'm trying to use the methods I found in Robo Recall to create a splash screen between levels. The splash screen is loading ok (although, I couldn't get it to display the textures in the editor) and then being removed. However, once it's removed, the level does not display. It's running in the background and can be seen if I switch stereo off, but the Oculus still has a black mask on it. It stays there if I try and run the preview again and doesn't go away until I restart the editor.

I set my camera fade to pink, so I know it's not that. I bound the loading screen to a controller button and that switches on and off over the black screen.

Is there another something I need to reset on the Oculus? Everything works fine when the ShowLoadingSplashScreen node is disconnected.

Product Version: UE 4.15
Tags:
more ▼

asked Mar 13 '17 at 05:59 PM in VR

avatar image

MrCheese
26 1 3 5

avatar image ndelchen Jan 22 '18 at 10:12 AM

Hey, did you find a solution to this? It seems that I'm facing a similar problem right now. The level is running in the background on the spectator screen, but it laggs a lot. The HMD only shows the guardian grid, everything else remains black.

avatar image MrCheese Feb 10 '18 at 05:30 PM

I can't remember really, I may have just had to wait until 4.16.

avatar image todernst Mar 25 '18 at 05:58 AM

I'm having this issue in 4.17. I've deleted all blueprint references to the splash screen. I can go from one map to the next when in the editor but it shows a white rectangle glitch and loading times now take longer. I tried adding the node Enable Loading Splash Screen with the boolean off and also Clear Loading Splash Screen to see if it was somehow stuck on there, but no change. I've deleted everything but the Content folder and migrated the levels but no luck

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Oculus has an auto loading splash screen that can at times get confused. You can disable it with a setting: [Oculus.Settings] bUseAutoLoadingSplashScreen=false

See OculusHMD_Splash.cpp in plugins for more details.

It's worth trying that to see if it fixes the problem. More commonly seen it with streaming level loads though.

more ▼

answered Apr 02 '18 at 05:55 PM

avatar image

TurtleSimos
368 3 7 20

avatar image todernst Apr 02 '18 at 06:16 PM

An Oculus engineer reached out to me with the solution. "There is an issue with the Loading Splash Screen in the editor where if the game is interrupted while the Splash Screen is active it will not allow itself to be reconfigured on subsequent runs unless hidden."

The following arrangement of Blueprint nodes worked for me. alt text

avatar image Badtz52 Jul 02 '18 at 04:27 PM

Did not work for me..

however, [Oculus.Settings] bUseAutoLoadingSplashScreen=false worked like a charm..

Note: this goes in the DefaultEngine.ini

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question