x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

macOS - Unreal Engine 4.13 - 4.16 hangs every few clicks.

Unreal Editor keeps hanging all over the place on my 15" Late 2013 Macbook Pro. This is happening in every version after 4.12.

alt text

I have tried fresh installing macOS, running the editor alone without other software installed without success. I have installed various Cuda drivers. Still no luck. I have tried to install previous versions of UE with previous versions of OSX. No success, since from 4.13 and onward I am struggling with unstable Unreal Engine versions, that just used to crash. This is something entirely new.

The editor keeps hanging at random intervals, even when doing simple tasks like adding a node to a blueprint, saving or switching folders in the content browser. It doesn't seem to be affected by the size of the project. I can't seem to recreate the problem or pinpoint what causes it. You can work fine for a whole day and the next day it hangs after 4-5 clicks, no matter what you do. I tried doing one thing in the editor (only placing meshes or only creating materials), it doesn't care, it just hangs when it feels like it. I tried reducing the resolution, disabling real time everywhere, from thumbnails to the material editor. I tried working with an empty vault, with projects without starting content. I tried running the editor without any USB device attached. I literally have tried almost everything but I can't get a UE to work, stable, as in 1-2 crashes per day. Crashes not hangs.

This problem started appearing a few versions back but now it happens so often it renders the Unreal Engine useless. As an IT pro troubleshooting things is what I do for a living, but this makes no sense at all.

No other software has issues on my MBP. None. Also all the hardware diagnostics check out nothing is wrong with my laptop.

Please help, I'm halfway through my project and I can't work with the editor anymore.

Product Version: UE 4.16
Tags:
more ▼

asked Mar 14 '17 at 10:34 AM in Bug Reports

avatar image

Sutorcen
181 7 13 18

avatar image Steve Hardister ♦♦ STAFF Mar 15 '17 at 03:22 PM

Hi Sutorcen,

In order for use to provide better support, please answer the following questions:

  1. Is the project that is crashing one that you have upgraded from a previous version of the Engine? If you have upgraded, did you keep a copy of the original?

  2. When UE4 Crashes, do you see the crash reporter pop-up Window? Did you hit the "submit" button to send us a copy of the Crash Report. If not, next time it crashes, please cut and paste the contents of the pop-up into a text doc and post here, then hit the "Submit" button.

  3. Under Settings>Preview Rendering Level> make sure you are using Shader Model 5.

  4. Lastly, please provide the following:

    • The UE4.log (Located: ~/Library/Logs/Unreal Engine/Editor/)

  5. The ProjectName.log (Located: ~/Library/Logs/Unreal Engine/ProjectNameEditor/)

Providing this information and appropriate logs will help us track down and isolate the source of the bug as quicklappropriate changelist upon tracking it down using the requested information.

Thank you for your cooperation in resolving this issue,

Steve H.

avatar image Sutorcen Mar 15 '17 at 06:37 PM

Hi Steve,

  • The editor hangs on old (created with older versions) and on newly created empty projects (created with 4.15).

  • The editor does not crash, it becomes unresponsive, I even wait for the os to recover the app but without success.

  • I am using Shader Model 5.

  • I would love to but there are no such logs in the location specified.

Let me know if I can do anything else to help resolve this issue.

avatar image Sutorcen Mar 20 '17 at 08:36 AM

In the risk of this being closed due to inactivity I have to ask. Do we have any suggestions regarding this problem? Besides buying a PC? Thank you in advance.

avatar image Steve Hardister ♦♦ STAFF Mar 20 '17 at 09:48 PM

We are looking into a possible bug involving Nvidia drivers which may or may not be the cause of the lagging you are experiencing. In the meantime, please try the following troubleshooting steps:

  1. Close all other programs and unplug any peripherals, esp. VR devices or anything that interacts with UE4 (but also smart mouse, etc.)

  2. If you have not already, please add a light importance volume to your project and size it so it just envelopes your scene.

  3. Also do this in a new blank Third Person Blueprint project (for testing)

  4. In both projects, reduce your Engine Scalability Settings and Material Quality settings to "Low"

  5. When building lighting, set the Lighting Quality to "Preview"

Do any of these actions dramatically effect the lagging? Does the Third Person blank template run significantly smoother than your custom project?

Please try these steps and respond accordingly and we will continue to investigate.

avatar image Sutorcen Mar 21 '17 at 08:50 AM

Thank you for your response.

Let's see

  1. I also thought that the second monitor might cause the problem so I have also tried working without it, there are no other devices connected to my MBP besides a Microsoft mouse which I have been using for years. I will try without it too.

  2. This didn't seem to affect the problem.

  3. Same as answer 2

  4. I will try that again. This was the solution on a Level where the MBP couldn't handle the complexity of the map. That particular level caused the Editor to crash and not hang. That was in 4.14. The same level performs better in 4.15, low frame rates but nothing out of the ordinary. When the Editor hangs it hangs even on a blank project with a blank map, performing tasks that have nothing to do with a level, like switching tabs.

  5. It is almost always in Preview quality.

This is what happened these past few days. Unreal Editor worked stable for a few hours on one day, without incident, then it started hanging (not responding) on another day. This goes on and on day in day out. Some days it works, some days it just wont work as described in the OP.

When it works, frame rates are generally better than 4.14 and are the best I've seen for a long time and the whole experience is snappier than 4.14 or previous versions. Crashes are rarer too. The only thing that drives me crazy is when Unreal Editor "decides" it does not "want" to work, even performing simple tasks. Like clicking on a button on one of the panels. The Editor hangs, the carousel appears instead of the mouse pointer and I have to force quit the Editor.

I am experimenting with various configurations trying to pinpoint the cause of this, from working with as few processes running in the background as possible, to working like I usually do with Photoshop, Firefox, Blender, Viber and Messages running in the background, yes on normal days it can handle all that just fine. I still can't seem to replicate the cause.

...continues on the next post

avatar image Sutorcen Mar 21 '17 at 08:50 AM

Something I have forgotten to tell you but might be relevant to this problem, is a general issue with the Unreal Editor windows on Mac that goes back to 4.7.

To avoid confusion. Main monitor = the screen on the laptop. Second monitor = external monitor connected to the laptop.

Prior to 4.15 and Sierra, when using the Unreal Editor on the MBP with a second monitor (without mirroring), I sometimes encountered a small misplacement of the mouse pointer on the second monitor. The mouse's clicks were way off from the pointer's actual location. Either the clicks were off or the graphic representation of the mouse pointer was off. That occurred only when you dragged a window (i.e. the editor's main window, the Content Browser or Material Editor) from your main monitor to the second monitor. If I use another software the problem is not there. Disconnecting and reconnecting the second monitor or switching mirroring options usually fixed that issue with Unreal. That was/is happening only with the Unreal Editor and no other software.

With 4.15 this still happens but with an added twist. Now I can only click at the title bar of an Unreal Editor window on the second monitor. This also happens on the main monitor as well if the Unreal Editor was opened on the second monitor and I drag a window to my main monitor.

Another issue appears oftentimes and only on the second monitor, 1/4 of the right most part of the screen appears to be a dead zone for the mouse, no clicks register. Again disconnecting and reconnecting the second monitor or switching mirroring options usually fixed that issue.

When you have the window of another software (lets say Firefox) in front of an Unreal Editor window, clicking on Firefox (the window in the front) ignores that window and brings the Unreal Editor to the front, even if the Unreal Editor is minimized. It is as if the Unreal Editor window frame never leaves the foreground as it should.

... continues on the next post

avatar image Sutorcen Mar 21 '17 at 08:51 AM

Last but not least clicking anywhere on an Unreal Editor window on the monitor other then the one you are currently working does not register as a monitor change. Only when you click at the title bar of an Unreal Editor window on the other monitor, does Unreal Editor realize that you want to switch monitors/Editor window.

Again all these happen only with Unreal Editor and no other software.

Sorry for the long posts but I think you should be aware of these issues.

I will try your suggestions and get back to you. Thank you.

avatar image Steve Hardister ♦♦ STAFF Mar 21 '17 at 07:01 PM

For troubleshooting purposes, disconnect the external display. Then choose Apple menu > System Preferences and click Energy Saver. Then deselect the automatic graphics switching checkbox. This is to test if dedicated graphics runs the editor more consistently and that your MacBook pro isn't switching graphics randomly.

Also, dock the editor in full screen and switch between tabs so that you do not have any floating windows/menus. Again, this is just to see if it makes a significant difference.

Lastly make sure you are running the latest version of Sierra in order to make sure you are running the latest GPU drivers.

avatar image Sutorcen Mar 22 '17 at 08:26 PM

I have been working without an external monitor these past few days.

I have automatic graphics switching deactivated by default.

The editor does not have an option to enter full screen (the <>) the green symbol at the top left corner, only the (+) symbol that maximizes the window, so in a sense it remains a floating window.

Both Sierra and the nVidia drivers are the latest versions available.

I will have to test the editor's stability a little bit more since 4.15.1 was just released, I will post any new findings.

avatar image Steve Hardister ♦♦ STAFF Mar 22 '17 at 08:53 PM

The machine I am testing for this bug on has the same specs as those you have listed for your machine except I do not typically use an external monitor but have access to one for testing. While I do not run a lot of programs in the background, I have more than one project open in one or more versions of the editor at the same time.

I have listed a number of settings and suggestions to try, including adding a light importance volume and lowering the rendering settings to their lowest in order to see if this makes any difference.... Have you tried these steps? Do they make any difference? Is UE4.15 the only version you are currently experiencing this lag on? Please provide this information -Thanks.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

All the settings you have suggested are the actions I usually take when faced with a situation and they didn't influence the problem, but I think we are getting somewhere. For the first time I have been able to recreate the problem and cause the Editor to hang at will.

I opened the Unreal Marketplace asset PUPI as a project in the Editor for the first time.

As expected it had to compile the shaders and as expected (for that particular project) it displayed the Message Log window on start up. This is where things get interesting.

If I close the Message Log Window a few seconds after the project loads, the Editor hangs and the Activity Monitor looks like in the image below. If I leave the Editor alone, without closing the Message Log, the Activity Monitor still displays the same load but the Editor does not become unresponsive and compiles the shaders without a problem.

alt text

If I click on any other area on the Editor it does not hang, switching windows, dragging the Message Log window to the secondary monitor and back, clicking inside the viewport, adding an actor to the Level, it does not hang. If I close the Message Log Window the Editor hangs.

Now the above Activity Monitor readings are nothing unusual since I oftentimes work like in the pictures below and I never had a performance issue:

alt text alt text

This is just my workflow when creating 3D assets for my projects but most of the time Unreal runs "alone" plus 1-2 apps. With the above "heavy" load, the Editor compiles shades, builds lights and pretty much used to work without a problem (with the occasional crashes but it never, ever hanged).

alt text

Further testing has showed that if I wait approximately 1 minute and 30 seconds, and then close the Message Log window the Editor works fine.

I have tried the above theory with various projects (blank, complex, older versions). Those that pop up an extra window (usually the Message Log) need a period of 1 minute and 30 seconds (± a few seconds) before I can close that window, else the Editor becomes unresponsive. I can interact with the editor from the get go as long as I don't close the extra window. If no extra window pops up when I load a project, I can begin work immediately.

Now this is a totally different behavior than 4.15.0 and the issues described in the OP. It seems that the problem I faced in the OP is gone with 4.15.1 and only this latest weird glitch remains. Let me know how I should proceed.

It seems like the Editor performs a bad call to Sierra during start that the OS or the Editor removes/kills after around 1 minute and 30 seconds.

more ▼

answered Mar 23 '17 at 09:21 AM

avatar image

Sutorcen
181 7 13 18

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

After an exhaustive day looking at everything inside the box for macOSX/CoreFoundation support, and a bunch of different fixes, the simplest seems to be the top (one I'll send a PR in for).

Because closing windows is already deferred, there seems to be a race condition between two threads when a window is closed. To counter this we simply say when its time to run the close call it isn't put off any longer (already is deferred a cycle).

Engine/Source/Runtime/Core/Private/Mac/MacApplication.cpp:1678 ( 4.18 code base )

Changes

more ▼

answered Jul 11 '17 at 03:20 AM

avatar image

Reapazor
6 2 2

avatar image Reapazor Jul 11 '17 at 03:46 AM
avatar image Sutorcen Jul 11 '17 at 07:38 AM

Nicely done, let's hope this is the source of the problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I recently had this start happening as well... I decided to take a more direct approach of figuring out what was locking up there editor, here's are the threads frames, showing the os lock. I had thought originally that it was related to Perforce, but you are correct on your 'around 1:30' seconds it locks up.

Something to note is that if you enter play mode prior to that, it doesn't seem to lock up till after you exit play-in-editor mode (in my case). We're talking within seconds it crashes.

I'll keep looking for a solution/narrowing this down, I'm thinking it might be related to the lazy loading of fonts for Slate

Main Thread Thread 1

The other threads are waiting nicely Thread 2 Thread-4

The NSEvent thread might be of interest ... Thread-8

more ▼

answered Jul 10 '17 at 01:33 AM

avatar image

Reapazor
6 2 2

avatar image Reapazor Jul 10 '17 at 01:58 AM

Confirmed still occuring in 4.16.2 rocket, with First Person BP.

avatar image Reapazor Jul 10 '17 at 02:26 AM

So it might actually be something a little more sinister, I can start the editor and just let it run and switch between tabs and everything is fine...

the second i 'right click' and bring up a context menu, be it in the game view, or in another editor window (content tab for example) ... if I click any option, or click off. ... it hangs.

avatar image Sutorcen Jul 10 '17 at 06:53 AM

Yes it is 4.16.2 and it still hangs after a few clicks. Epic Games had it for a moment with 4.12 but after that it was downhill from there. Personally I'm very disappointed with Unreal Engine on Mac, so much that I actually considered for a moment switching to Unity. I even considered sending Epic Games my laptop as is. The situation is that bad.

Some workarounds that might or might not work include:

  • Running only Unreal Engine 4.

  • Running it on your main monitor only (without a second one connected, I know this sucks).

  • Letting Unreal load and not do anything for a minute or so.

  • Don't connect /use USB drives while using Unreal Engine 4.

I don't know, at this stage they might have something to do with UE crashing all the time or not or maybe it's a placebo effect. You want my advice? Buy a PC, I'm about to. Too bad though because If we ever want to release anything on a Mac or even iOS, we're doomed and there doesn't seem to be a fix on the way anytime soon.

Btw everything else runs flawlessly on my Mac.

If an admin is reading this thread please return it to an UNSOLVED status.

avatar image Reapazor Jul 10 '17 at 12:39 PM

Haha cause those work arounds are real life ready :)

So I'm gonna go on a hunt today through the latest source (4.18), this is suppose to be their 'Mac' fix build so we'll see what I find; atleast this way I can break out when it hangs and start debugging / push a PR. I need this to work, and will fix it.

avatar image Reapazor Jul 10 '17 at 02:08 PM

It's still in 4.18, but im narrowing down where it occurs ;)

Attached stack trace. alt text

avatar image Reapazor Jul 10 '17 at 06:02 PM

While not practical, not disposing of the windows actually prevents it from hanging ... now the much more interesting problem is that those functions are CoreFoundation functions and this SHOULDNT be happening :)

alt text

avatar image Reapazor Jul 10 '17 at 06:12 PM

It could be possible that a window has a delegate that is being notified about its close and its taking a nose dive, but i wouldnt think delegates would hang the process

avatar image Reapazor Jul 10 '17 at 06:20 PM

Doesnt look like it, i commented out the message handler, but still does it ...still keeping at it ... wont give up :D

avatar image Reapazor Jul 10 '17 at 06:43 PM

So ... by removing the corefoundation call

             for (FCocoaWindow* Window : WindowsToClose)
             {
                 // issue close to CoreFoudation
                 //[Window close];
                 
                 // clear memory
                 [Window release];
             }


it seems to not happen... it feels wrong though ... :( cause then any delegates assigned wont get a callback from CF

avatar image Sutorcen Jul 10 '17 at 06:55 PM

The thing is that the Editor behaves irrational. It can hag every few clicks for hours and suddenly work without problem for hours, with the same apps open in the background. Somewhere the Editor makes a bad call and it hangs.

avatar image Reapazor Jul 10 '17 at 07:00 PM

This is a call that happens quite frequently, and happens outside of most other events.

By commenting out the disposing of the windows it hasnt had a problem :) But then again, its not properly telling anything tied to the window that it is closing, so I'm looking at that now, and tonight. We're getting there..

avatar image Sutorcen Jul 10 '17 at 07:08 PM

The Editor has various issues with its windows. Either they flicker when you move them between screens/monitors, lose the pointer tracking, minimize but leave a ghost window lingering.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question