x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unauthorized access to libmedia.so

When I run my game on Android I get a message

 Detected problem with app native libraries (please consult log for detail):
 libvrapiimpl.so: unauthorized access to "/system/lib/libmedia.so"

In my log I found:

 W/linker(6352): library "/system/lib/libmedia.so" ("/system/lib/libmedia.so") needed or dlopened by "/data/app/com.oculus.systemdriver-1/lib/arm/libvrapiimpl.so" is not accessible for the namespace "classloader-namespace" - the access is temporarily granted as a workaround for http://b/26394120, note that the access will be removed in future releases of Android.

but this is only a warning. The problem occured when I upgraded my device to Android 7. Should I add some special permission to the Android manifest if I want to use libmedia.so?

Here I found the exact problem but according to this I need to rebuild UnrealBuildTool. Is there another way to solve this issue?

Product Version: UE 4.15
Tags:
more ▼

asked Mar 14 '17 at 02:50 PM in Packaging & Deployment

avatar image

Koralgoll
400 15 21 43

avatar image Matthew J ♦♦ STAFF Mar 15 '17 at 03:11 PM

Hello Koralgoll,

From looking at the links you provided, have you tried what fixed the issue for brockheinz on the Oculus forums? He mentioned that having "Debuggable" in the manifest caused this issue for him. Have you tried this in any other projects that have Gear VR enabled or is it only in your project?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I tried to remove android:debuggable="true" from Android Manifest under Intermediate/Android but those files are overwritten while building .apk. I have not changed this from source code. However I disabled the Oculus Rift plugin in the editor and the problem seems to be gone for now.

more ▼

answered Mar 16 '17 at 03:57 PM

avatar image

Koralgoll
400 15 21 43

avatar image Matthew J ♦♦ STAFF Mar 16 '17 at 05:47 PM

The Oculus Rift plugin shouldn't be required for Gear VR, so if disabling this plugin resolves the issue, that should be a valid fix. Does this work for you?

avatar image Koralgoll Mar 17 '17 at 03:04 PM

With the Oculus Rift plugin disabled the error is not showing up, but when I enable the plugin again the error is not showing up either. My app is working fine now but I guess it is not a proper solution.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question