x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Progress bar not working

Hello. I have a problem with progress bar. I used this tutorial https://www.youtube.com/watch?v=Snz99qBh9qQ and when I create FirstPerson Project c++ code and progress bar is working. But when I create Puzzle Project or Blank Project c++ progress bar not working. I create level blueprint in blank project. alt text

and I see alt text I read that this problem occurs because my Character not created. I created him, added camera and changed level blueprint. alt text because my Character camera not working if I leave this connect. Character Blueprint: alt text

and see that my progress bar still not working,

My Camera should be static. I have 2 cameras (CineCameraActor and MyCharacter with camera). alt text

And I cant to found info about my problem. Where I miss something or do wrong?

Product Version: UE 4.14
Tags:
screenshot_4.jpg (60.5 kB)
screenshot_5.jpg (39.1 kB)
screenshot_6.jpg (57.2 kB)
screenshot_7.jpg (26.1 kB)
screenshot_8.jpg (9.6 kB)
more ▼

asked Mar 16 '17 at 12:37 PM in Blueprint Scripting

avatar image

Sh1ftO_o
1 1 3 3

avatar image Knight9871 Mar 16 '17 at 04:29 PM

can i see your progress bar blueprint if you have one so i can try and help?

avatar image Sh1ftO_o Mar 17 '17 at 08:16 AM

yes, sure alt text whole logic of progress bar written in C++

screenshot_10.jpg (93.1 kB)
avatar image Knight9871 Mar 17 '17 at 02:37 PM

i dont know but mabye if you did it looks like you turned the cast(cast to MainCharacter)(mabye turn it make to a normal cast) to one of those pure things that may be the problem

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

i don't know if you tried this it may not work it just came to the tip of my mind so i am speaking aloud my thoughts: have you tried some how casting it to the third person or first or topdown or what ever then getting the player controller. tell me if this helps at all. i could help more if i had the project or could see all the blueprints and more. hope this helps if it does'nt i will try and think of a way to help you!

more ▼

answered Mar 16 '17 at 04:33 PM

avatar image

Knight9871
25 3 3 4

avatar image Sh1ftO_o Mar 17 '17 at 08:22 AM

https://bitbucket.org/Sh1ft/ue4_blankgame problem precisely not in C++code, because I've debugged C++ code and it works correctly

avatar image Knight9871 Mar 17 '17 at 02:03 PM

wait to you fixed it? or what?

avatar image Sh1ftO_o Mar 17 '17 at 06:19 PM

no i can't fixed it. I dont understand where blueprint can't be calling, because c++ code works correctly

avatar image Knight9871 Mar 18 '17 at 01:15 AM

ok i will try out your project and try and fix it for you , is that fine with you?

avatar image Sh1ftO_o Mar 18 '17 at 05:33 AM

try it, because I don't understand how to fix it

avatar image Knight9871 Mar 18 '17 at 11:12 PM

ok can you give me a download link?

avatar image Knight9871 Mar 20 '17 at 03:37 PM

ok i am trying it out now

avatar image Knight9871 Mar 23 '17 at 09:43 PM

it wont let me use it

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question