x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.15] DataTable, recompile and hotreload bug

I added two new properties to my table row struct in C++ and then compiled using hot-reload. The two new properties were not showing on my datatable editor so I restarted the editor. Once I restarted the editor I found out that my data table asset is now corrupt, it's trying to reference a hotreloaded struct as the row struct for the datatable when it should reference my "standard" struct, so all my table data is lost. For some reason the editor saved the hotreloaded row struct as the row struct reference for the data table asset.

Screenshot:

alt text

Product Version: UE 4.15
Tags:
more ▼

asked Mar 16 '17 at 09:03 PM in Bug Reports

avatar image

Sveitar
1k 8 24 26

avatar image MutualWolf Mar 17 '17 at 10:45 AM

Hey Sveitar, I ran into a similar issue with data assets in 4.12. Did you save your data table before hot reloading, or were there unsaved changes? I think unsaved changes during hot reload could be the culprit here.

avatar image Sveitar Mar 17 '17 at 06:40 PM

I always tend to save before playing in editor, so yes, I'm almost sure that I saved before hot reloading. Either way it should be fixed. The engine should never save that HOTRELOADED reference into the asset.

avatar image Doug E ♦♦ STAFF Mar 22 '17 at 07:58 PM

Hey Sveitar-

What class does your struct exist in? Can you provide the code for your struct and repro steps to help me reproduce the issue on my end?

avatar image Sveitar Mar 23 '17 at 02:52 AM

Hi Doug!

The struct is inside of its own header file, the code is attached.

I didn't experience the issue again, but the steps are pretty much what I said in the first post. As I remember I added two properties and hot reloaded the project from editor. Let me know if I can help you with anything.

Thanks! link text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Sveitar-

Thank you for submitting a bug report. I have reproduced this issue and logged a report for it here https://issues.unrealengine.com/issue/UE-43408 . You can track the report's status as the issue is reviewed by our development staff. Please be aware that this issue may not be prioritized or fixed soon.

Cheers

Doug Wilson

more ▼

answered Mar 28 '17 at 05:32 PM

avatar image Undianer May 03 '19 at 02:30 PM

We now have version 4.22.1 and it is still not fixed -.-

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question