x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unable to build Google VR Project

Hi all,

Had issues building projects at work, so now trying at home and really appreciate help. I have a Moto G, generation 01 with an ample sized SD card. I was running Unreal 4.14/ Win 8 and managed to put a working build on my phone following the beginner guide here: https://docs.unrealengine.com/latest/INT/Platforms/GoogleVR/QuickStart/2/index.html

I've since upgraded to windows 10, Unreal 4.15 and have the same Phone, freshly formatted with SD card. I've made a new start project and followed the tutorial steps exactly. I have also installed Visual Studio 2013 Community Edition, Android SDK, and I have not been able to build successfully. There are so many factors that I am struggling to work out exactly what is the problem. I have followed the tutorial exactly (and repointed to each of the SDK/ NDK/ JS etc folders) and tried to build an Android-24 build, no joy, and changing to Android 21 or Android 19 also does not work. Please can someone advise on my next step, I really appreciate help with this.

Furthermore, it looks from the error log that I am facing that it is an issue with the Phone, although this is on a freshly formatted phone, so I cannot see how it could be this? It worked on a different OS, so surely it cannot suddenly have broken at the same time as an OS upgrade?

Here is a screenshot of the latest attempt. In this one, I have set minimum SDK to Android-19, Maximum to Android-24. I have also set the SDK and NDK Api level to latest (although changing every one of those options to 24 or 21 also does not work for me, and if I set them all to 19 then it does not build the batch file itself correctly. alt text

thank you.

Product Version: UE 4.15
Tags:
capture.png (304.8 kB)
more ▼

asked Mar 17 '17 at 09:43 PM in Packaging & Deployment

avatar image

Alex Scott
51 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It must be something with your devices OS upgrade as the error your getting is: "no_matching_abis"

Try exporting with armv7 instead of arm64 and vice versa? (step 12 in that quick start link)

more ▼

answered Apr 19 '17 at 06:34 PM

avatar image

aussieburger
1.5k 43 176 75

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question