x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal editor "crashes" on launch

Hi!

I finally had time to boot my PC again to start on a project in Unreal, but:

When I started the editor the splash screen showed, but when the load status was at 0% my screen blacked out. Testing with the UT game from launcher: Screen black, intro voice plays.

alt+f4, ctrl+alt+delete, alt+tab,win+d etc: nothing worked. Left computer on, no dice. I had to turn it off using the power button.

Reinstalled PC completely with updated win 10 (home edition, 64 bit), updated drivers etc: Same problem. Moved the engine install: same problem. Launched the editor from project location, with admin rights and still same problem.

Please note that no changes to the engine where made, no files modified in any way by me. I just installed the launcher, added 4.15 engine and tried to launch it from the launcher.

The Unreal crash reporter did not show up.

The one thing that has changed in my setup since this worked is my monitor. I now use a Dell U2711(connected with display port cable).

Other HW: Gforce gtx 670 i7-3770k 16 GB ram Intel SSD

NB: Other games, like Overwatch works as they should.

My gut feeling is that the editor somehow sends a non compatible signal to my monitor, but really I am at a loss on what to do, all tip are welcomed!

Regards, Eirik

Product Version: UE 4.15
Tags:
more ▼

asked Mar 19 '17 at 12:19 PM in Bug Reports

avatar image

EirikRaude
6 1 2 3

avatar image EirikRaude Mar 20 '17 at 09:09 PM

After reading in the log files a bit I found this: [2017.03.19-11.25.04:403][ 0]LogStandaloneRenderer: D3D11CreateDevice Result: 0 [2017.03.19-11.25.04:545][ 0]LogInit: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467 [2017.03.19-11.25.04:560][ 0]LogUdpMessaging: Initializing bridge on interface 0.0.0.0:0 to multicast group 230.0.0.1:6666. [2017.03.19-11.25.04:614][ 0]LogStreaming:Warning: Failed to read file '../../../Engine/Plugins/Messaging/MessagingDebugger/Content/GroupBorder.png' error.

There was quite a few of theese errors.

avatar image EirikRaude Mar 20 '17 at 09:10 PM

The last lines of the log file:

[2017.03.19-11.45.15:357][983]WinReg: ERROR: Could not create registry value SOFTWARE\EpicGames\Unreal Engine\4.15/InstalledDirectory. Error Code 5: Access is denied.

[2017.03.19-11.45.22:772][983]WinPlatform: Elevated spawn attempt: Success: true, Return Code: 0 [2017.03.19-11.45.22:773][983]FCommunityPortalPatcher: Change State Patching->Success [2017.03.19-11.45.22:789][983]LogOnline:Verbose: OSS: Large tick time detected 9.0630 [2017.03.19-11.45.22:793][984]FCommunityPortalPatcher: Change State Success->Idle [2017.03.19-11.45.35:220][705]DEBUGSZ old=0 new=8 [2017.03.19-11.45.35:236][706]DEBUGSZ old=8 new=9 [2017.03.19-11.45.35:252][707]DEBUGSZ old=9 new=11 [2017.03.19-11.45.35:268][708]FCommunityPortalLaunchAppTask: Launching app 'C:/Unreal/UE_4.15/Engine/Binaries/Win64/UE4Editor.exe' with commandline ' -EpicPortal '

avatar image EirikRaude Mar 20 '17 at 10:21 PM

Display driver updated to 378.92 and engine reinstalled to 4.15.1. Same problem.

avatar image TJ V ♦♦ STAFF Mar 22 '17 at 07:27 PM

Hey Eirik,

You mentioned that you launched the editor from the project location, do you mean that you attempted to launch the editor directly from the .exe? If not, could you please try that? It will help determine where the error is occurring.

:\Program Files (x86)\Epic Games\4.15\Engine\Binaries\Win64\UE4Editor.exe

Also, please upload a copy of your Dxdiag (system specs) and the entire log file that you are pasting the data from.

  • Windows: Go to the Start menu and type ‘dxdiag’ into the search bar. Open the file and then click ‘Save All Information’. Post that text file here.

avatar image EirikRaude Mar 22 '17 at 08:32 PM

Hi!

Thank you for the reply. I have tried launching the editor from 4.15\Engine\Binaries\Win64\UE4Editor.exe, with the same result. Please note that I have installed it on a non standard location at the moment (c:\unreal) as I have tried to reinstall the engine. I can reinstall to default location if you belive that will be helpful.

DX diag

dxdiag.txt (68.2 kB)
avatar image EirikRaude Mar 22 '17 at 08:40 PM

Note: I just tested it with the 4.13.2 engine and that works without problem.

I deleted old logs and started 4.15.1 from launcher with debug mode active

[1]: /storage/temp/131286-logs.zip

logs.zip (141.3 kB)
avatar image TJ V ♦♦ STAFF Mar 28 '17 at 02:00 PM

Can you also get the engine logs from this folder?

C:\Users\YourName\AppData\Local\UnrealEngine\4.15\Saved\Logs

Also try disabling any programs like GeForce Experience that are running in the back ground.

Installing in a non-default location 'shouldn't' cause any issues but you can try uninstalling and then reinstalling in the default engine location to see if that makes a difference.

avatar image EirikRaude Mar 30 '17 at 10:00 AM

Please see the log files attached to this post.

I uninstalled GeForce experience and 3dvision ++ (see the screenshot).

Same problem as before unfortunately.

[1]: /storage/temp/132130-capture.png

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Installing Visual Studio resolved the issue for some unknown reason.

more ▼

answered Apr 05 '17 at 05:06 PM

avatar image

EirikRaude
6 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question