x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

VR preview with dedicated server

Hey,

When i am trying to run the VR preview option in Unreal without a dedicated server it works just fine, however when i click the check box to run through a dedicated server i can't see anything in my oculus HMD, everything is black.

I appreciate all the help, thanks!

Product Version: UE 4.14
Tags:
more ▼

asked Mar 20 '17 at 01:03 PM in VR

avatar image

chedrasmus
21 2 2

avatar image migo Oct 05 '17 at 07:26 PM

Did you find solution? On 4.17 still don't work.

avatar image Ecnassianer Oct 16 '17 at 02:29 AM

At my old studio we had this problem. I don't remember the details of how we fixed it, but there's some problem with the way the VR Editor Mode works that conflicts with the dedicated server. An engineer on our team disabled VR Mode and got dedicated server working and it was my favorite day in the world.

avatar image migo Oct 16 '17 at 09:30 AM

So ask him when have possibility, I'm not using VR Editor, just VR mode in game preview, its multiplayer game with dedicated server and testing it with VR is nightmare. I'll be glad for tip how to disable VR mode on dedicated in way to be able still test dedicated + vr preview as client.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I had what may be the same problem, which was due to the Oculus automatic loading screen support not detecting that level loading had finished so it left up a black screen. If it is that, then adding a call from BeginPlay on the level blueprint to HideLoadingSplashScreen with clear ticked worked around the problem for me.

more ▼

answered Mar 24 '17 at 05:42 PM

avatar image

TurtleSimos
368 3 7 20

avatar image chedrasmus Mar 28 '17 at 11:30 AM

Hi, thanks for your answer. Sadly this didn't work for me. I did as you said and set the clear to true, the same problem occurred.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

If you can modify the engine, applying like the following code will work.

Incidentally the first call of this function is for dedicated server.
2nd and later are for client.
I put it on 4.19.

 UGameInstance* UEditorEngine::CreatePIEGameInstance(int32 InPIEInstance, bool bInSimulateInEditor, bool bAnyBlueprintErrors, bool bStartInSpectatorMode, bool bRunAsDedicated, float PIEStartTime)
 {
     const FString WorldPackageName = EditorWorld->GetOutermost()->GetName();
     
     bool bUseVRPreview = bUseVRPreviewForPlayWorld && (InPIEInstance >= 0 && InPIEInstance <= 1);
     if( !bRunAsDedicated && bUseVRPreviewForPlayWorld && VRInstanceSpawned == false )
     {
         VRInstanceSpawned = true;
         bUseVRPreview = true;
     }

more ▼

answered Oct 02 '18 at 01:00 PM

avatar image

TakashiSuzuki
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question