x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

sucessfull package but ue4game_win64_shipping.exe crash on startup .

crash

i made a game using 100% blueprint . game pack success , no error and 1 warning , game.exe work fine no problem but ue4game_win64_shipping.exe will crash on startup . my question is , is it suppose to crash ? I mean is it normal to crash because I actually only need game.exe to run the game ? but the documentation state otherwise . how can I solve this ? can I use game.exe as the main launcher for my game ?

additional info : packed as shipping , pak true , encrypt true , success true , full build true , playable after packed yes but only game.exe .

i also made a new project and pack it sucessfully . but still the UE4Game_win64_shipping.exe won't launch , only game.exe are playable without any error whatsoever .

output log : [2017.03.20-14.11.08:938][294]UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2017.03.20-14.11.08:927][ 0]LogInit:Display: [2017.03.20-14.11.08:938][294]UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2017.03.20-14.11.08:927][ 0]LogInit:Display: Warning/Error Summary (Unique only) [2017.03.20-14.11.08:938][294]UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2017.03.20-14.11.08:927][ 0]LogInit:Display: ----------------------------------- [2017.03.20-14.11.08:938][294]UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2017.03.20-14.11.08:927][ 0]LogInit:Display: LogCore:Warning: Package localization ID mismatch during cook! Expected '9A1F8F1D4E229DA83523D5A276CAD40C', got '6BA78DB8482355AA785220909897A4DC'. Namespace: '', Key: '919E42544A68DF1FA2EC2EBCDDE6BEFF', Source: 'PRESS E'. [2017.03.20-14.11.08:938][294]UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2017.03.20-14.11.08:927][ 0]LogInit:Display: [2017.03.20-14.11.08:938][294]UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2017.03.20-14.11.08:927][ 0]LogInit:Display: Success - 0 error(s), 1 warning(s) [2017.03.20-14.11.08:938][294]UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2017.03.20-14.11.08:927][ 0]LogInit:Display: [2017.03.20-14.11.08:939][294]UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2017.03.20-14.11.12:917][611]UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: Execution of commandlet took: 559.13 seconds [2017.03.20-14.11.18:584][628]UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2017.03.20-14.11.12:861][ 0]LogOnline:Display: Unloading online subsystem: NULL [2017.03.20-14.11.18:585][628]UATHelper: Packaging (Windows (64-bit)): CommandUtils.Run: Run: Took 634.8070521s to run UE4Editor-Cmd.exe, ExitCode=0 [2017.03.20-14.11.18:917][629]UATHelper: Packaging (Windows (64-bit)): Project.Cook: COOK COMMAND COMPLETED [2017.03.20-14.11.18:918][629]UATHelper: Packaging (Windows (64-bit)): Project.CopyBuildToStagingDirectory: STAGE COMMAND STARTED [2017.03.20-14.11.18:918][629]UATHelper: Packaging (Windows (64-bit)): Project.CreateStagingManifest: Creating Staging Manifest... [2017.03.20-14.11.21:250][636]UATHelper: Packaging (Windows (64-bit)): Project.CleanStagingDirectory: Cleaning Stage Directory: G:\game dev\Unreal Projects\Perfect_Plan\Saved\StagedBuilds\WindowsNoEditor [2017.03.20-14.11.21:251][636]UATHelper: Packaging (Windows (64-bit)): Project.CreatePakUsingStagingManifest: Creating pak using staging manifest. [2017.03.20-14.11.21:583][637]UATHelper: Packaging (Windows (64-bit)): Project.RunUnrealPak: Running UnrealPak [2017.03.20-14.11.21:584][637]UATHelper: Packaging (Windows (64-bit)): CommandUtils.Run: Run: D:\Program Files\Epic Games\UE_4.15\Engine\Binaries\Win64\UnrealPak.exe "G:\game dev\Unreal Projects\Perfect_Plan\Saved\StagedBuilds\WindowsNoEditor\Perfect_Plan\Content\Paks\Perfect_Plan-WindowsNoEditor.pak" -create="C:\Users\Amirulradzi\AppData\Roaming\Unreal Engine\AutomationTool\Logs\D+Program+Files+Epic+Games+UE_4.15\PakList_Perfect_Plan-WindowsNoEditor.txt" -encryptionini -enginedir="D:\Program Files\Epic Games\UE_4.15\Engine" -projectdir="G:\game dev\Unreal Projects\Perfect_Plan" -platform=Windows -installed -order="G:\game dev\Unreal Projects\Perfect_Plan\Build\WindowsNoEditor\FileOpenOrder\CookerOpenOrder.log" -UTF8Output -multiprocess -patchpaddingalign=2048 [2017.03.20-14.11.26:583][652]UATHelper: Packaging (Windows (64-bit)): UnrealPak: LogPakFile:Display: Loading response file C:\Users\Amirulradzi\AppData\Roaming\Unreal Engine\AutomationTool\Logs\D+Program+Files+Epic+Games+UE_4.15\PakList_Perfect_Plan-WindowsNoEditor.txt [2017.03.20-14.11.26:583][652]UATHelper: Packaging (Windows (64-bit)): UnrealPak: LogPakFile:Display: Added 4052 entries to add to pak file. [2017.03.20-14.11.26:584][652]UATHelper: Packaging (Windows (64-bit)): UnrealPak: LogPakFile:Display: Loading pak order file G:\game dev\Unreal Projects\Perfect_Plan\Build\WindowsNoEditor\FileOpenOrder\CookerOpenOrder.log... [2017.03.20-14.11.26:584][652]UATHelper: Packaging (Windows (64-bit)): UnrealPak: LogPakFile:Display: Finished loading pak order file G:\game dev\Unreal Projects\Perfect_Plan\Build\WindowsNoEditor\FileOpenOrder\CookerOpenOrder.log. [2017.03.20-14.11.26:584][652]UATHelper: Packaging (Windows (64-bit)): UnrealPak: LogPakFile:Display: Collecting files to add to pak file... [2017.03.20-14.11.26:584][652]UATHelper: Packaging (Windows (64-bit)): UnrealPak: LogPakFile:Display: Collected 4052 files in 0.04s. [2017.03.20-14.13.53:666][567]UATHelper: Packaging (Windows (64-bit)): UnrealPak: LogPakFile:Display: Added 4052 files, 695392646 bytes total, time 147.08s. [2017.03.20-14.13.53:666][567]UATHelper: Packaging (Windows (64-bit)): UnrealPak: LogPakFile:Display: Compression summary: 30.57% of original size. Compressed Size 592732316 bytes, Original Size 1939214987 bytes. [2017.03.20-14.13.53:667][567]UATHelper: Packaging (Windows (64-bit)): UnrealPak: LogPakFile:Display: 34 files requested encryption, but no AES key was supplied! Encryption was skipped for these files [2017.03.20-14.13.54:000][568]UATHelper: Packaging (Windows (64-bit)): CommandUtils.Run: Run: Took 152.3432854s to run UnrealPak.exe, ExitCode=0 [2017.03.20-14.13.54:000][568]UATHelper: Packaging (Windows (64-bit)): Project.RunUnrealPak: UnrealPak Done [2017.03.20-14.13.54:000][568]UATHelper: Packaging (Windows (64-bit)): Project.CopyManifestFilesToStageDir: Copying NonUFSFiles to staging directory: G:\game dev\Unreal Projects\Perfect_Plan\Saved\StagedBuilds\WindowsNoEditor [2017.03.20-14.13.57:000][577]UATHelper: Packaging (Windows (64-bit)): Project.CopyManifestFilesToStageDir: Copying DebugFiles to staging directory: G:\game dev\Unreal Projects\Perfect_Plan\Saved\StagedBuilds\WindowsNoEditor [2017.03.20-14.13.57:000][577]UATHelper: Packaging (Windows (64-bit)): Project.CopyBuildToStagingDirectory: STAGE COMMAND COMPLETED [2017.03.20-14.13.57:000][577]UATHelper: Packaging (Windows (64-bit)): Project.Package: PACKAGE COMMAND STARTED [2017.03.20-14.13.57:334][578]UATHelper: Packaging (Windows (64-bit)): Project.Package: PACKAGE COMMAND COMPLETED [2017.03.20-14.13.57:335][578]UATHelper: Packaging (Windows (64-bit)): Project.Archive: ARCHIVE COMMAND STARTED [2017.03.20-14.14.03:333][596]UATHelper: Packaging (Windows (64-bit)): Project.Archive: ARCHIVE COMMAND COMPLETED [2017.03.20-14.14.03:333][596]UATHelper: Packaging (Windows (64-bit)): Automation.Execute: BUILD SUCCESSFUL [2017.03.20-14.14.03:333][596]UATHelper: Packaging (Windows (64-bit)): Program.Main: AutomationTool exiting with ExitCode=0 (Success)

please help meeeee .... :(

Product Version: UE 4.15
Tags:
more ▼

asked Mar 21 '17 at 03:43 AM in Packaging & Deployment

avatar image

Amirulradzi
11 1 2 4

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Amirulradzi,

Please use the .exe file that's located in the WindowsNoEditor.

WindowsNoEditor

Thank you!

more ▼

answered Mar 22 '17 at 02:35 PM

avatar image Amirulradzi Mar 23 '17 at 06:21 PM

ouh no , thanks you ma'am :D it is such a relief to know that i can do that , i'm super confused & confused before this , glad this is not a problem no more :D have a great day :D

avatar image Samantha Sutton ♦♦ STAFF Mar 24 '17 at 06:55 PM

You're welcome, let us know if you have any further questions. :)

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question