x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

No 32-bit compiler toolchain found

I installed visual studio 2017. When I try to create a new C++ project or add C++ to my existing BP Project the following error pops up - ERROR: No 32-bit compiler toolchain found in C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\cl.exe

I have searched and googled and I cannot get this problem solved.I've reinstalled UE and VS already I have tried installing VS first then UE and the other way around I have cleared my temp folders and Cache's Tried with UE 4.14 , 4.15.0 and 4.15.1 Ive tried installing ALL additional components in the VS2017 installer

Please help me any suggestions would be appreciated

Product Version: UE 4.15
Tags:
more ▼

asked Mar 20 '17 at 06:23 PM in C++ Programming

avatar image

MadMarsza
22 3 3 6

avatar image MadMarsza Mar 21 '17 at 05:37 AM

Unfortunately I deleted my temp folder,I posted my problem on The VS forums and they suggested I delete my temp folder,worked for someone else so I don't have the installation log file anymore.After doing A search I can confirm the file does exist but in the same folder you mentioned above and a few other folders.(C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.10.25017\bin\Hostx86\x86\cl.exe), C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.10.25017\bin\Hostx86\x64\cl.exe, C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.10.25017\bin\Hostx64\x86\cl.exe, C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.10.25017\bin\Hostx64\x64\cl.exe

I will try and copy files around and then post my reply,Thanks

avatar image MadMarsza Mar 21 '17 at 06:07 AM

Okay this partially worked.after copying A LOT of files around based on different errors that I was getting this is my error that I am stuck with at the moment

The project could not be compiled. Would you like to open it in Visual Studio?

Running C:/Program Files/Epic Games/UE_4.15/Engine/Binaries/DotNET/UnrealBuildTool.exe MyProject5 Development Win64 -project="C:/Unreal/MyProject5/MyProject5.uproject" -editorrecompile -progress -NoHotReloadFromIDE Performing full C++ include scan (building a new target) Creating makefile for MyProject5 (no existing makefile) @progress push 5% Parsing headers for MyProject5Editor Running UnrealHeaderTool "C:\Unreal\MyProject5\MyProject5.uproject" "C:\Unreal\MyProject5\Intermediate\Build\Win64\MyProject5Editor\Development\MyProject5Editor.uhtmanifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -Unattended -WarningsAsErrors -installed Reflection code generated for MyProject5Editor in 3.3788674 seconds @progress pop Performing 8 actions (4 in parallel) [2/8] Resource ModuleVersionResource.rc.inl [3/8] Resource PCLaunch.rc PCH.MyProject5.cpp cl : Command line error D8027 : cannot execute 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\amd64\c1xx.dll' ERROR: UBT ERROR: Failed to produce item: C:\Unreal\MyProject5\Binaries\Win64\UE4Editor-MyProject5.dll Total build time: 8.08 seconds (Local executor: 0.00 seconds)

Please note the file (C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\amd64\c1xx.dll') does exist

avatar image Javideas May 12 '17 at 03:03 PM

see the comment downbelow by @Newest :D

(comments are locked)
10|2000 characters needed characters left

4 answers: sort voted first

Try to install C++ on VS 2015, Unreal 4.16.2 has dependency on VS2015

more ▼

answered Jul 30 '17 at 11:33 AM

avatar image

MehranJanfeshan
36 4 1

(comments are locked)
10|2000 characters needed characters left

I had the same issue. I had VS 2015 and 2017 installed (and project was made in UE4.15)

My solution:

  1. deinstalled VS 2017

  2. reboot

  3. change VS 2015 istallation: checked everything that got "c++" and "tool" in the name

  4. reboot

  5. in UE4: Editor Preferences -> source code -> Visual Studio 2015

  6. UE4 newstart

  7. (for safety: Check again if Substance plugin is enabled.) Build for 64 bit Windows.

  8. Works.

So the system gots confused by the versions and also there was no c++ stuff for VS2015 installed.

Cheese

more ▼

answered Mar 29 '17 at 12:02 PM

avatar image

CodiBasti
11 2 4

avatar image Javideas May 12 '17 at 03:01 PM

THANKS!!!!! I just loggin to say it: @Newest made it! That's the solution :) ! I spend like two hours reinstalling(downloading) "everything with c++ o tool in the name" for VS 2015. With each step exactly as @Newest says. Even Go to Editor Preferences, the newstart.... all the before restart.... If you do it as @Newest says you are gonna be happy. Thanks again!

(comments are locked)
10|2000 characters needed characters left

Have you tried going to the "Individual Components" tab of the VS 2017 installer and selecting the VC++ 2015.3 v140 toolset (x86,x64) and the Windows 8.1 SDK. I don't think they are selected by any of the "Workloads" on the main screen (although they obviously should be by the "Game development with C++") and both are required for rebuilding UE4.

more ▼

answered Mar 20 '17 at 06:58 PM

avatar image

Matthias Hölzl
411 13 6 19

avatar image MadMarsza Mar 20 '17 at 07:05 PM

Thanks for the answer.Yes,Due to the frustration of getting this to work I installed EVERYTHING in the individual components tab![alt text][1]

avatar image MadMarsza Mar 20 '17 at 07:12 PM

I also uninstalled everything,VS and UE and after setting up a new admin account on my windows I redownloaded and reinstalled everything including all the components again,Still the exact same error

avatar image ExtraLifeMatt Mar 20 '17 at 07:22 PM

What Environment Variables do you see set? If you have 2017 installed I would expect you to have one named VS150COMNTOOLS that points to something like:

C:\Program Files (x86)\Microsoft Visual Studio 15.0\Common7\Tools\

avatar image Matthias Hölzl Mar 20 '17 at 09:57 PM

First of all a stupid question: The file does really not exist, does it?

Can you look into the log files, whether the cl.exe file from the VS14 package was installed somewhere? The logs should be in your user folder under AppData/Local/Temp (`AppData` is hidden by default). The log file is named with the date and a serial number, so I can't tell you the exact name, but it should be something like /dd_setup_20170319072531_255_Microsoft.VisualCpp.Tools.HostX86.TargetX86.log.

Interestingly enough, the installation paths mentioned in this file do not seem to contain all the locations where the corresponding files are found on my machine. My log file claims that the cl.exe file was installed into C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.10.25017\bin\Hostx86\x86\cl.exe (which is true) but they contain no entries for the path mentioned in your error message except for definitions:

 ./dd_vs_community_20170319071104.log:[0550:0AE8][2017-03-19T07:23:30]i410: Variable: CustomInstallPath = C:\Program Files (x86)\Microsoft Visual Studio 14.0\
 ./dd_vs_community_20170319071104.log:[0550:0AE8][2017-03-19T07:23:30]i410: Variable: DevEnvAppIdKeyPath = C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\devenv.exe
 ./dd_vs_community_20170319071104.log:[0550:0AE8][2017-03-19T07:23:30]i410: Variable: VSComponentPathVariable = C:\Program Files (x86)\Microsoft Visual Studio 14.0\

However the files are definitely in the directory that CustomInstallPath mentions, so I guess the installer copies stuff around at a later stage. Unfortunately there is nothing logged that confirms this. But perhaps your log might give some hints about what has gone wrong. Or maybe you could try copying the folders mentioned in these paths by hand.

avatar image MadMarsza Mar 21 '17 at 06:29 AM

I am repairing VS installation now,after moving all the files around this might fix everything up,otherwise it will revert everything back to the way it was,If this does not work I am going to do a fresh install of windows and then again redownload and install everything but instead of all the individual components I will only install VC++ 2015.3 v140 toolset (x86,x64) and the Windows 8.1 SDK.I think I have too many VS installations and different stuff in my folders and it is confusing everything.I also think this is an isolated problem so reinstalling should fix everything,and if it doesn't then I know it is not an isolated problem

avatar image MadMarsza Mar 20 '17 at 08:02 PM

I don't I have VS140COMNTOOLS pointing to C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\Tools\

(comments are locked)
10|2000 characters needed characters left

Working after moving files around and then doing a repair from the installation.Thanks for all the help

more ▼

answered Mar 21 '17 at 09:54 AM

avatar image

MadMarsza
22 3 3 6

avatar image Hyperion Rising Mar 24 '17 at 02:13 PM

Can I ask what you did to fix it? Repairing installation doesnt work for me.

avatar image Javideas May 12 '17 at 03:02 PM

see the comment down below by @Newest :)

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question