x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

VR camera position is close to floor

I use the first person template which I then to run in VR (Oculus). When I preview it in VR, using the play button, the camera position is perfect. As soon as I launch my environment (using launch button with VR enabled in the project settings), my camera is very close to the floor. I've read some articles about the change in settings prior to v4.11 but that doesn't apply to me (since I started development with v4.13). Lock to HMD is also enabled for my camera. I've reset all my settings again to default but the same issue applies.

I've tried many things, including changing the capsule height of my character blueprint, raising the camera, change eye height etc. It does improve by changing capsule height but it's still very low to the ground. Anybody who can assist please? Thanks in advance.

Update: when I restart the level or have a node to reset the orientation while in VR, the problem occurs again. I thyen started a basic first person FPS project and run it directly in VR and immediately, the problem occurs (character is very close to the ground) so it is not related to my personal settings. What is wrong?

Product Version: UE 4.14
Tags:
more ▼

asked Mar 21 '17 at 06:52 PM in VR

avatar image

Superfunkstar
62 9 10 18

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Hi TurtleSimos,

I finally solved the problem! Resetting the sensor didn't fix it but it can be solved with 3 simple steps: Everything is done in the First Person Character blueprint:

  1. Set the camera to the bottom of the capsule

  2. Add a node "set tracking origin" in the blueprint of your character where it is checked (also FPC blueprint) if the HMD (oculus rift) is connected.

  3. Create a simple scene component and make it parent of the camera (and controls). Set its location (Z-value) to -80 or any other value that you want. Now, my characters appears at normal height in my environment. Finally!!

more ▼

answered Apr 05 '17 at 03:48 PM

avatar image

Superfunkstar
62 9 10 18

avatar image RIPAN44 Oct 16 '18 at 11:15 AM

Thank you so much it worked for me. I just added a capsule collider component to the blueprint.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Make sure you have a call to set the tracking origin. SetTrackingOrigin in Blueprint. This can be eye level or floor level. If you're not setting it, it could be defaulting to eye level which would give the symptoms you describe.

more ▼

answered Mar 24 '17 at 05:37 PM

avatar image

TurtleSimos
368 3 7 20

avatar image Superfunkstar Apr 04 '17 at 01:27 PM

Hi TurtleSimons,

thanks a lot! You solved half of my problem. By adding that node (set to floor level), at least I'm not close to the floor anymore but, unfortunately, now I'm too high (about 50 cm above my size, which is about 1m70). I can manipulate the capsule size but I have the feeling that I shouldn't touch that (since my head navigation isn't accurate anymore if I do that). I also tried to adjust the eye height, set to camera position to the ground etc but it doesn't seem to lower the height. Any suggestions?

avatar image TurtleSimos Apr 05 '17 at 06:52 AM

Try re-run the sensor tracking for the Rift. Settings/Devices/Configure Rift menu/Reset Sensor Tracking. It's been getting better as Oculus versions go up but sometimes it seems to lose the setting. There is also set floor position in case you have your height set wrong. Then check with a clean UE VR template - see if the head height is correct there. Assuming it is there and not in your project, gradually remove bits of your project until it gives the right height and then you'll have isolated where the problem is. But best to have a base VR template as a known good reference point first in case your Oculus setup is not playing ball.

avatar image Superfunkstar May 11 '17 at 07:25 PM

Thanks for the tip. Will check the vr template. Adding the node for floor position solved the problem entirely, if I recall correctly. Thanks!

avatar image VRMMO Sep 19 '17 at 09:08 PM

Guys I am having this problem too but I don`t understand the solution.

Are there screenshots of the blueprints?

Where do I attach the set tracking origin box?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

You can also add "Get Base Eye Height" and plug that in to your Z value and then you don't have to manually set the Z value if you update your character eye height.

more ▼

answered Aug 13 '17 at 07:45 PM

avatar image

mvollrath
1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

where do i find Z value and plug the set origin tracking in FPC Blueprint.alt text

bp.png (190.9 kB)
more ▼

answered Jan 28 '18 at 01:42 PM

avatar image

Murthy_Lucky
1 1

avatar image mvollrath Jan 29 '18 at 03:30 PM

Here's an example of the setup I've been running. I haven't really had issue with the vive eye height, only the occulus.

To note I have this in the same blueprint that you are showing above

Anyway, I hope this helps you

alt text

avatar image BenjvC Mar 19 '19 at 06:30 PM

Hello mvollrath, I found this thread while searching for an issue with Vive, so maybe you could throw me a bone. Project behaves just fine in Editor via Play VR preview, SteamVR all solid green when packaging, build shows successful, but when I launch player I see on my monitor the camera is born at ground level, though the HMD is on my desk, and putting on the HMD I only see the default grey scene (responds to head movement), but no video from game coming in, though I do hear audio from the game. So, HMD is talking to SteamVR, but something going lost with UE4. Any thoughts? Big thanks.

Benjy

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question