x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

HTML5 package on Server

I can't find what I need to do in order to make my package work elsewhere than in the folder HTML5 produced after packaging (C:\UE4_builds\HTML5). I can't even move the package in a diffent folder without getting an error see : alt text This is what I get when I use

I also tried to put it on a server see what I get on chrome and firefox nightly chrome : alt text

Firefox nightly: alt text

I followed these tutorials : https://docs.unrealengine.com/latest/INT/Platforms/HTML5/GettingStarted/ https://docs.unrealengine.com/latest/INT/Platforms/HTML5/

And some Forum post like :

https://answers.unrealengine.com/questions/331691/how-to-deploy-a-html5-game-on-apache.html

Product Version: UE 4.15
Tags:
more ▼

asked Mar 22 '17 at 01:06 AM in Packaging & Deployment

avatar image

OmniProgrammerCE
1 1 2 4

avatar image juj Mar 22 '17 at 11:44 AM

Does the browser's web page console show any messages? (right-click on page, choose Inspect Element, then choose Console tab)

Do all the network downloads complete successfully with 200 OK and no HTTP 404? (the Network tab next to the Console tab should show all network transfers and their results)

Is there an online link or a zip file to build that could be used to check?

avatar image OmniProgrammerCE Mar 23 '17 at 01:53 PM

The link is : cybereducation.ca/Logiciels/professeurs/InterfaceProfesseur-HTML5-Shipping.html [link text][1]

On firefox with Inspect Element --- Console Tab, I get :

" Current Browser : Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0" InterfaceProfesseur-HTML5-Shipping.html:259 "We are running in 32 bit browser, clamping requested memory size of 1073741824 bytes to 536870912" InterfaceProfesseur-HTML5-Shipping.html:260 TypeError: asm.js type error: 'min' is not a standard Math builtin blob:6bfeac8d-5112-470c-b663-97e628c9f40a:3 Error: WebGL: texImage2D: with format of DEPTH_COMPONENT or DEPTH_STENCIL, target must be TEXTURE_2D, data must be nullptr, level must be zero blob:6bfeac8d-5112-470c-b663-97e628c9f40a:1 Error: WebGL: texSubImage2D: format blob:6bfeac8d-5112-470c-b663-97e628c9f40a:1 Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://datarouter.ol.epicgames.com/datarouter/api/v1/public/data?SessionID=%7B00291178-2E03-0917-002B-0332068D70B2%7D&AppID=UEGame.Rocket.Release%7C35105CBB4B8EE759804C47936EAAECDB%7CInterface%20Professeur&AppVersion=4.15.1-3348071%2B%2B%2BUE4%2BRelease-4.15&UserID=ANON-%7B00281A15-2E03-0917datarouter/api/v1/public/data?SessionID=%7B00291178-2E03-0917-002B-0332068D70B2%7D&AppID. This can be fixed by moving the resource to the same domain or enabling CORS. data "Source map information is not available, emscripten_log with EM_LOG_C_STACK will be ignored. Build with "--pre-js $EMSCRIPTEN/src/emscripten-source-map.min.js" linker flag to add source map loading to code." InterfaceProfesseur-HTML5-Shipping.html:404 "warning: build with -s DEMANGLE_SUPPORT=1 to link in libcxxabi demangling" InterfaceProfesseur-HTML5-Shipping.html:404 "DebugBreak() called! ...

avatar image TheMainStark Feb 06 '18 at 09:13 AM

I'm having this issue as well:

 "Source map information is not available, emscripten_log with EM_LOG_C_STACK will be ignored. Build with "--pre-js $EMSCRIPTEN/src/emscripten-source-map.min.js" linker flag to add source map loading to code." 

Did you ever find a fix for this?

avatar image nick.shin STAFF Feb 06 '18 at 05:23 PM

we don't use that feature anymore. UE4 use's emscripten's "--profiling-funcs" option to always (debug/developer builds only) have the call stack printable in demangled format NOTE: look at the console.log output to see this which may not be printed on the browser page

https://github.com/EpicGames/UnrealEngine/blob/release/Engine/Source/Programs/UnrealBuildTool/Platform/HTML5/HTML5ToolChain.cs#L233-L250

so also note: shipping builds will go back to the mangled function name format. but, you can copy and paste the c++ name mangled lines to: https://demangler.com/ to get it back to "normal".

avatar image TheMainStark Feb 07 '18 at 08:54 AM

This is happening on a shipping build that I have uploaded to a host. I'm a bit confused in your response on how I'm supposed to fix this error? My web console output is attached.

Any help would be super appreciated!

[1]: /storage/temp/229820-error.txt

error.txt (14.3 kB)
avatar image nick.shin STAFF Feb 07 '18 at 04:57 PM

you're asking me a different question than what the OP asked -- a different runtime crash.

for the sake of clarity - please open a new post and PM me the link.

but first, i'm going to ask you to try the following:

  • get latest of UE4 (4.18 -- note: 4.19 is just around the corner)

  • build developer version

  • getting the line number of where the assert is happening is vital to figuring out where in the code the check() is failing

  • your error message seems vaguely familiar... and i know something was fixed (i just don't remember when -- so i'm thinking 4.19 will fix your issue)

again, please post a new issue - this thread should be closed.

avatar image juj Mar 23 '17 at 02:47 PM

Tried out the page, and works well at least on Firefox Nightly 55.0a1 (2017-03-17) (64-bit) on Mac OS X. The resize bug is there like expected, I think that will be fixed in UE 4.16. I wonder if the issue could be a 32-bit vs 64-bit..

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

the fix for the resize issue will be in for 4.16. it didn't make it to the 4.15 lockdown.

but the following post may help:

*https://answers.unrealengine.com/questions/531986/html5-widget-interaction-area-offset.html

more ▼

answered Mar 23 '17 at 07:49 PM

avatar image

nick.shin STAFF
476 5 4 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question