x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Error trying to upgrade C++ project to new version of Unreal (4.15)

I'm trying to update from 4.14.3 to 4.15.1, but having problems with the Hot Reload.

I'm having the following error:

 CompilerResultsLog: Info ERROR: Couldn't find target rules file for target '-canskiplink' in rules assembly 'UE4Rules, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.
 CompilerResultsLog: Info Location: C:\Program Files\Epic Games\UE_4.15\Engine\Intermediate\Build\BuildRules\UE4Rules.dll
 CompilerResultsLog: Info Target rules found:
 CompilerResultsLog: Info     UE4Editor - C:\Program Files\Epic Games\UE_4.15\Engine\Source\UE4Editor.Target.cs
 CompilerResultsLog: Info     UE4Game - C:\Program Files\Epic Games\UE_4.15\Engine\Source\UE4Game.Target.cs
 CompilerResultsLog: Info     UnrealHeaderTool - C:\Program Files\Epic Games\UE_4.15\Engine\Source\Programs\UnrealHeaderTool\UnrealHeaderTool.Target.cs

It is compiling fine in the Visual Studio, and also creating new classes, but the Hot Reload is always giving this error message.

I already tried deleting Binaries and Intermediate folders and Regenerate Visual Studio project files, also Rebuild project from Visual Studio, but nothing is working.

Product Version: UE 4.15
Tags:
more ▼

asked Mar 22 '17 at 02:14 AM in Installation & Setup

avatar image

Andre.D.F.182
3 1 3 7

avatar image RomuVdr Mar 25 '17 at 02:00 PM

same error, did you find a solution ?

avatar image Andre.D.F.182 Mar 25 '17 at 09:40 PM

Not yet. I decided to wait to try to upgrade when the 4.16 version comes. I am seeing a lot of users having problems to upgrade to this new version, so I hope Epic solves those problems :(

avatar image Tim C ♦♦ STAFF Apr 13 '17 at 08:19 PM

Hi Andre,

Is this still an issue for you? Would you be able to provide any more information about when you see this happening?

  • Are you using the binary version of the Engine that is installed by the Launcher, or did you build the Engine from source code?

  • Does this only happen in your project, or do you see the same issue occur in a new test project?

  • What process did you use to upgrade your project to 4.15?

  • What edits are you making to your code prior to starting a Hot Reload?

  • How do you start the Hot Reload?

Tim

avatar image Andre.D.F.182 Apr 15 '17 at 04:32 PM

I didn't tried to to this again. I am using the Binary version of the Engine. I tried to create new projects with the 4.15.1 version, but had another problems.

With this version the further I reached was this attempt and had this problem with the Hot Reload. In other tries I coudn't even open the project.

To upgrade from the 4.14.3 to the 4.15.1 version I just opened the .uproject with the new version and upgraded locally, in the same project.

It was Compiling successfully in the Visual Studio, but showing this error message when I've tried to Compile with Compile Button from the Unreal Engine.

In general, this was the only problem I've got in this attempt, but I decided to continue with the 4.14 version a little longer until the 4.16 maybe, to avoid other problems.

avatar image Tim C ♦♦ STAFF Apr 17 '17 at 06:01 PM

I tried upgrading a 4.14 project made with the Binary version of the Engine to 4.15, and still did not see any issues related to hot reloading. Would it be possible to get a copy of the project that is giving you trouble so I can try upgrading that specific project? Also, are there any plugins that you are using in your project?

Tim

avatar image Andre.D.F.182 Apr 25 '17 at 12:49 AM

We tried again and same errors. Using no plugins. I upload a ZIP with the project if you wanna try. I appreciate if you can help.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi Andre,

I am very sorry for the delayed response to this post. Thank you for providing the sample project that you did. I was able to reproduce the issue that you described, and I believe the issue is actually a result of the name of the project. Version 4.15 included our initial support for the Nintendo Switch platform, and 4.16 included full support for that platform. If you are able to change the name of your project to something else, this issue should go away.

Tim

more ▼

answered Jun 09 '17 at 02:55 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Finally, I found a solution in my case:

XXX.Target.cs in your source code: Where XXX MUST BE the name of the project name Due to a clone operation, it was different.

more ▼

answered Mar 26 '17 at 06:18 PM

avatar image

RomuVdr
36 1 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question