x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

all my stuff broke

Ive think this got me

ive been working on my game for two months i can say i have a lot of blueprints

i am making a first person game focused on narrative and game play evryting was fine on the 3/22/2017

but the next day i opened the editor to work on my game and this happend (its really long so i will explain how it works first and the the problem)

  1. all of my blueprints stoped working, even level blueprints dont work anymore

  2. my player character spawns in the viewport location when it is not even supposed to spawn

  3. no Level sequences play at all not even console commands played by blueprints

  4. Aiming offset does not work , not even the blending blueprint any blueprint

5.pretty much evriting broke on functionality

  1. the only thing that works is that i can rotate left or right but no up and down by the aim offset

  2. and my custom blueprint trigger system (let me explain) well the system works like this and its not broke except for this thing that happend
    player collide with trigger trigger sends text to game mode objects react if the text of the game mode = their text and works

ive tried the follloing

make new project, coppy the content folder

still breaks i will show some picks of evriting at least the player

and a level blueprint

alt text

this is the level blueprint

alt text

The game mode blueprint

alt text

the player movement blueprint and pitch and yaw

alt text

The aiming part of the animationBP

alt text

this on is with no game-mode selected and still the player spawns however there is no way for me to move on any direction only rotate left or right and all of my trigger system objects broke = does not work literally

all blueprints dint work any more

i think this is an engine bug sort a because i get no error when running but nothing works

maybe my game will never see the end of the tunnel

-Cheers with love.

Product Version: UE 4.14
Tags:
more ▼

asked Mar 22 '17 at 02:44 PM in Using UE4

avatar image

Jeanc1212
5 1 3

avatar image Mosel3y Mar 22 '17 at 02:56 PM

Might you be simulating instead of playing?

alt text

Also in your level blueprint on the first CreateLevelSequence node, there is no asset selected, is that intentional?

s.png (27.8 kB)
avatar image Jeanc1212 Mar 22 '17 at 05:17 PM

its not set to simulate, also the level sequence mode is intentional

also i notice that the player when ever it spawns it has no gravity to and somehow the player(Character) wants the always spawn on the level

PS. I recently installed visual studio 2010 express 2 days before this bug occurred i don't know if tats the case

but yesterday the game worked perfectly fine

but now its not doing well

any way so how can i upload my project so i can get check

but im afraid that the project goes on the wrong hands

-Cheers

avatar image Mosel3y Mar 22 '17 at 05:26 PM

You can use File>Package Project>Zip Up Project, it will add it to a zip archive that you could upload somewhere like Google Drive or Dropbox.

If you don't want everyone to have the link, you can PM me on the forums and I can check for you. Or, if/when someone from Epic support sees your question, they will probably offer to do the same if they can't tell what is going on.

Have you tried right-clicking you Map file in content browser, and migrating it to a blank project? Asset Actions>Migrate Then seeing if you get the same problem in that project?

edit: also, check in project settings that your default Map/GameMode/Game instance etc. are set as you want them

avatar image Jeanc1212 Mar 22 '17 at 05:57 PM

I can't send PM but here's the link then

some things first of the project the load map actually worked before this broken thing so i deleted the level blueprint trying to figure out if the problem was fixed but the level that goes after the Load Level its the Menu and then The intro

i hope you find something

  • Cheers

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

In your game mode Fps_Single_game, set your GameStateClass, to GameStateBase. (At the moment, it's GameState).

This fixed the issue for me, so maybe try that. Do you need to use GameState?

more ▼

answered Mar 22 '17 at 08:50 PM

avatar image

Mosel3y
1.8k 49 22 67

avatar image Jeanc1212 Mar 24 '17 at 02:21 PM

Thanks, it worked , so curious that one little thing can cause a lot of head pain

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question