x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cannot Package on macOs - No AutomationTool.exe

Just installed a fresh prebuilt 4.15.1 from game launcher on macOs

I cannot package as AutomationTool.exe is missing:

 UATHelper: Packaging (Mac): Running AutomationTool...
 UATHelper: Packaging (Mac): Setting up Mono
 UATHelper: Packaging (Mac): Start UAT: mono AutomationTool.exe -ScriptsForProject=/Users/neonphog/projects/ModSkeleton/ModSkeleton.uproject BuildCookRun -nocompile -nocompileeditor -installed -nop4 -project=/Users/neonphog/projects/ModSkeleton/ModSkeleton.uproject -cook -stage -archive -archivedirectory=/Users/neonphog/projects/ModSkeleton/tmp -package -clie
 ntconfig=Development -ue4exe=UE4Editor -compressed -pak -prereqs -nodebuginfo -targetplatform=Mac -build -CrashReporter -utf8output
 UATHelper: Packaging (Mac): Cannot open assembly 'AutomationTool.exe': No such file or directory.
 UATHelper: Packaging (Mac): RunUAT ERROR: AutomationTool was unable to run successfully.
 PackagingResults:Error: Error Invalid Arguments
 

If I create a custom launch profile, and check Build UAT, I get:

 Running AutomationTool...
 Setting up Mono
 Compiling AutomationTool with xbuild
 xbuild Source/Programs/AutomationTool/AutomationTool.csproj /p:Configuration=Development /p:Platform=AnyCPU /verbosity:quiet /nologo /p:TargetFrameworkProfile=
 /Users/Shared/Epic Games/UE_4.15/Engine/Binaries/ThirdParty/Mono/Mac/lib/mono/4.5/Microsoft.CSharp.targets: error : Error executing tool '/Users/Shared/Epic Games/UE_4.15/Engine/Binaries/ThirdParty/Mono/Mac/lib/mono/4.5/mcs.exe': ApplicationName='/Users/Shared/Epic Games/UE_4.15/Engine/Binaries/ThirdParty/Mono/Mac/lib/mono/4.5/mcs.exe', CommandLine='/noconfig @/var/folders/j0/lv1k2cds61188hhnly6fgxz00000gn/T/tmp386baeaa.tmp', CurrentDirectory='/Users/Shared/Epic Games/UE_4.15/Engine/Source/Programs/DotNETCommon/DotNETUtilities', Native error= Cannot find the specified file
 /Users/Shared/Epic Games/UE_4.15/Engine/Binaries/ThirdParty/Mono/Mac/lib/mono/4.5/Microsoft.CSharp.targets: error : Error executing tool '/Users/Shared/Epic Games/UE_4.15/Engine/Binaries/ThirdParty/Mono/Mac/lib/mono/4.5/mcs.exe': ApplicationName='/Users/Shared/Epic Games/UE_4.15/Engine/Binaries/ThirdParty/Mono/Mac/lib/mono/4.5/mcs.exe', CommandLine='/noconfig @/var/folders/j0/lv1k2cds61188hhnly6fgxz00000gn/T/tmp6cf1a254.tmp', CurrentDirectory='/Users/Shared/Epic Games/UE_4.15/Engine/Source/Programs/UnrealBuildTool', Native error= Cannot find the specified file
 /Users/Shared/Epic Games/UE_4.15/Engine/Binaries/ThirdParty/Mono/Mac/lib/mono/4.5/Microsoft.CSharp.targets: error : Error executing tool '/Users/Shared/Epic Games/UE_4.15/Engine/Binaries/ThirdParty/Mono/Mac/lib/mono/4.5/mcs.exe': ApplicationName='/Users/Shared/Epic Games/UE_4.15/Engine/Binaries/ThirdParty/Mono/Mac/lib/mono/4.5/mcs.exe', CommandLine='/noconfig @/var/folders/j0/lv1k2cds61188hhnly6fgxz00000gn/T/tmp7d830f2.tmp', CurrentDirectory='/Users/Shared/Epic Games/UE_4.15/Engine/Source/Programs/AutomationTool/AutomationUtils', Native error= Cannot find the specified file
 _wapi_handle_unref_full: Attempting to unref unused handle 0x2852
 _wapi_handle_unref_full: Attempting to unref unused handle 0x2853
 _wapi_handle_unref_full: Attempting to unref unused handle 0x2866
 _wapi_handle_unref_full: Attempting to unref unused handle 0x287b
 RunUAT ERROR: AutomationTool failed to compile.
Product Version: UE 4.15
Tags:
more ▼

asked Mar 22 '17 at 05:21 PM in Packaging & Deployment

avatar image

neonphog
1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Got it working, though I'm not sure what went wrong...

I deleted my whole "/Users/Shared/Epic Games/UE_4.15/" directory, then had the Epic Games Launcher repair the installation... and now it seems to be working.

Very strange.

more ▼

answered Mar 22 '17 at 07:12 PM

avatar image

neonphog
1 2

avatar image Ratamorph May 01 '17 at 04:02 PM

I have the same issue, sadly this didn't solve it in my case. Also cannot package plugins. Everything works on 4.14.

avatar image joshmmo May 25 '17 at 08:48 PM

Deleting unreal (4.16 in my case) and removing the space in "Epic Games" to "EpicGames" for the install directory fixed the issue for me.

avatar image AnkhM_ Jul 31 '17 at 06:59 AM

For me, Unreal 4.16.2, I'd just make a "repair" on the launcher and it works fine.

avatar image TTimo Nov 14 '17 at 07:05 PM

We ran into this as well with 4.17.2 - the fix was to rename 'Epic Games' to 'EpicGames' as mentioned above.

Note that "/Users/Shared/Epic Games/UE_4.17.2/..." is the default path used by the launcher. So this would significantly affect all MacOS users?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question