x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Performances with foliage in 4.15

Hi,

I have worst performances with foliage (grass and trees) in 4.15 than before... And I don't know why ? I know that an issue exist with the grass output node : https://answers.unrealengine.com/questions/574896/grass-tool-causing-massive-performance-drop.html but even if the foliage tool has better performance than the grass output node, I can't understand why performances are worst than before and I just want to know if other people are like me ?

Thanks, and sorry for my English,

Dorian.

Product Version: UE 4.15
Tags:
more ▼

asked Mar 22 '17 at 06:07 PM in Rendering

avatar image

Dorian B.
46 2 5 10

avatar image KuroSekaie Mar 23 '17 at 11:56 AM

I can Confirm thats there are Really performance Drops on Foliage in 4.15. I guess its the Grass NODES Landscape material System..but i Dont Know, i just get a WAY Worser performance than on 4.14! , and thats on my 1070.. When im Under an Tree , and Walk in the SHADOW my FPS DROPS TO 40 Whitout a REASON.

Thats a Problem.. i cant Convert my Project Back to 4.14, because the Maps are not Compatible.

Hope They Made a Fast Fix

I Use 4.15.1

avatar image Dorian B. Mar 23 '17 at 05:37 PM

Thanks for your message, I hope too that this will be fixed very soon... Or just get more informations... I'm happy to don't be the only one in this case !

Dorian.

avatar image Dorian B. Mar 24 '17 at 08:24 PM

Can we get more information about that ? I can't find more information, but this is a really big problem for me, all my game envirnoments are broken, i can't get more than 30 fps with foliage... I have an old save in 4.14, but i did a lot of work since... I hope we will have more information in the coming days.

Dorian.

avatar image JaroMast Jul 14 '17 at 01:42 PM

Epic, maybe you could comment on this issue?

I have exactly the same problem and no answer from anyone from any staff member. There is a big performance drop since 4.14, now 4.17 is coming out and still, you are not planning to do anything with it?

avatar image rabellogp Jul 27 '17 at 01:04 PM

Have you found a solution (or at least a concrete reason for the issue) yet? I'm also struggling with that (https://answers.unrealengine.com/questions/658509/inconsistent-lod-behavior-on-foliage-and-grass.html)

It's probably related to the way the engine clusters foliage instances together (it changed from 4.14 to 4.15 and newer somehow). Bug or not, I haven't found a clear answer to that yet... More related (and unanswered) questions here:

https://answers.unrealengine.com/questions/675188/foliage-clusters-and-lods.html

https://answers.unrealengine.com/questions/604328/fps-drop-after-migrate-project-4143-416.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey Dorian!, Try to Convert a Project Again!, I Converted it AGAIN from 4.14 to 4.15, and Erased all Lights, and Recreated it , and Look at Some Settings of the lights!, May theres a Problem!

After i Converted it Again and Looked at all Settings AO Distance Field Distance etc , I have now DREAM Fps, More FPS than on 4.14! Like on 4.14 i got 100-110 Fps on 4.15 i got now 120-140 FPS,

KS

more ▼

answered Mar 24 '17 at 10:04 PM

avatar image

KuroSekaie
83 11 13 16

avatar image Dorian B. Mar 25 '17 at 02:32 PM

Hi,

I had converted my project back in 4.14 and again in 4.15 but that changed nothing for me... I think I'll try with my old save, and I didn't understand what you say about lights settings? I tried some settings, but that's not better... I hope I'll find something or I think I'll go back in 4.14 and lose 1 months of works...

Thanks for trying to help me, Dorian.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I found the problem... : https://answers.unrealengine.com/questions/567764/asset-migration-breaks-lod-screen-sizes-bug-report.html. Then I need to change all LOD for all my foliage meshes... That's not cool, but I found a solution at least.

Dorian.

more ▼

answered Mar 25 '17 at 09:12 PM

avatar image

Dorian B.
46 2 5 10

avatar image Dorian B. Mar 26 '17 at 07:11 PM

That doesn't solve the problem... I think I'll stop my project while the problem is not solved, work for nothing is useless...

Dorian.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question