x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

This file does not have a program associated

Hello,

So I Reformatted my PC and installed the Launcher + UE4.15.

I am able to make a project and load a existing project whilst UE4 is open. After Setting the .uproject default program to UE4Editor.exe I am now able to open them directly.

However when I try to load a project from inside the launcher both new and old, I am prompted with the error message

alt text

I am unsure what to do.

Cheers

Product Version: UE 4.15
Tags:
capture.png (6.4 kB)
more ▼

asked Mar 23 '17 at 08:36 PM in Installation & Setup

avatar image

Kuuwahi
45 6 12 15

avatar image Maxwell_n11 Mar 24 '17 at 07:54 AM

Hello,

same error for me, trying to re-install the engine and the launcher, clean some windows registry key about "Epic Games" and still not working.

avatar image Kuuwahi Mar 24 '17 at 11:24 PM

Well,

I have just formatted my entire PC, Removed all Epic Games Related content (Except Projects).

And came back to the same issue.

(comments are locked)
10|2000 characters needed characters left

6 answers: sort voted first

Hi there,

Thank you for the report. The launcher is supposed to be registering uproject file associations for you, we are looking into why that could no longer be working.

In the meantime, the best way to workaround the problem would to manually register using the correct tool, provided with the launcher.

Here is a step by step example on Windows 10

Please let me know if anyone is having issues with this, too.

Navigate to the launcher install directory, and find UnrealVersionSelector.exe

For me, it is located here:

C:\Program Files (x86)\Epic Games\Launcher\Engine\Binaries\Win64\UnrealVersionSelector.exe

Right-click the exe and select Create Shortcut option.

alt text

On this new shortcut file, right-click and select properties. Then, in the Target field, add -fileassociations to the end, and press Apply. It should look like this:

alt text

Now right-click the shortcut again, this time select Run as Administrator. After a short time, uproject files should now work correctly, including context menus items that look like so:

alt text

shot1.png (6.7 kB)
shot2.png (22.1 kB)
shot3.png (8.3 kB)
more ▼

answered Mar 30 '17 at 02:01 PM

avatar image

leighswift STAFF
1.8k 38 136 42

avatar image Kakushi_52 Mar 31 '17 at 06:48 AM

Thank you so much for the instruction! I think one of the possible reason is that Unreal Engine is now installed to

C:\Program Files\

folder instead of

C:\Program Files (x86)\

at least with the latest launcher.

Previously, both Unreal Engine and Launcher had been installed to

C:\Program Files (x86)\

Now, with the latest Launcher, Launcher is still installed to

C:\Program Files (x86)\

and each Unreal Engine is installed to

C:\Program Files\

avatar image Kuuwahi Mar 31 '17 at 08:20 AM

I don't think this is the root of the issue to be honest. As mine has always been installed in its own directory on a dedicated SSD (S:/Epic Games)

avatar image leighswift STAFF Mar 31 '17 at 08:59 AM

Thank you for the comments. We have identified the issue and working on releasing the fix asap.

avatar image AngrySpartan Apr 02 '17 at 06:25 PM

I am also experiencing this problem. I purchased a new computer over the weekend. My team has recently upgraded our current project to 4.15 from 4.14. My old pc was running Win 10 Professional, this new one is is running Win 10 Home. Not sure if that makes a difference. However, I have been running through the forums all day looking for a solution. I have this problem with projects downloaded from our team source control, projects in 4.14., 4.15, new projects I created. However, at one point i was able to get the project to load if I launched engine and then selected the project. So, somehow, the version selectors is not in the install. After searching through the soultions here,

Each solution references this file

UnrealVersionSelector.exe

This file is nowhere to be found. I looked in the both Epic program locations. The launcher in the C:\Program Files (x86)\Epic Games\Launcher\Engine\Binaries\Win64\

and the engine folders in C:\Program Files\Epic Games\

Right-Click mene

File Association

This is also happening on laptop. Running Win 10 Edu. Macbook that has been bootcamped.

avatar image leighswift STAFF Apr 04 '17 at 03:18 PM

Hey all, since the Launcher update 2.12.27, the issue should be fixed now and anyone without the correct associations should be prompted.

Thanks again!

avatar image Real_Distiny Mar 20 '18 at 08:20 PM

works like a charm, thanks !

(comments are locked)
10|2000 characters needed characters left

Hello,

I have solved my problem by copy the content of Launcher > Binaries > Win64 and paste to the 4_15 > Binaries > Win64 after that I have executed the UnrealVersionSelector.exe inside the 4_15 Win64.

A dialog window ask me if it's the directory is an unreal engine installation, click on yes and a message appear "Successfull registration" everything work now.

I hope that can help you.

more ▼

answered Mar 25 '17 at 12:18 PM

avatar image

Maxwell_n11
36 1 8

avatar image Kuuwahi Mar 25 '17 at 12:35 PM

Not sure how you discovered this, However after following your solution I can now confirm that this worked for me and all projects now load via the launcher.

avatar image Maxwell_n11 Mar 25 '17 at 02:05 PM

Discover after 3 days of trying ;) glad to see it's working for you.

avatar image TonsTheGamer Apr 02 '17 at 09:55 PM

Can you help me out please I'm lost as to where you're speaking about. If it's the C:\Program Files (x86)\Epic Games\ or the Program Files alone and what exactly did you copy Sir? Please help? I really want this to work. Maybe you can contact me on discord so it's easier for me?

avatar image TonsTheGamer Apr 02 '17 at 10:04 PM

I have to confirm that this method is truly correct. Thank you so much for sharing this advise!

(comments are locked)
10|2000 characters needed characters left

Hello Kuuwahi,

Your issue appears to be with the launcher, and not the engine itself, for help with launcher issues please visit http://help.epicgames.com/

Thanks

more ▼

answered Mar 24 '17 at 01:44 PM

avatar image

Thomas G ♦♦ STAFF
7.3k 64 4 53

avatar image Kuuwahi Mar 25 '17 at 12:38 PM

After Contacting Via the link you provided, they initially said it wasn't their dept and to post on here. After I explained that I had they took a look at this page then forwarded it on to the launcher department to which I am waiting for a reply.

However as seen below, I followed this persons solution which solved the issue.

avatar image Kakushi_52 Mar 30 '17 at 06:08 AM

Mr. ThomasVanZeeland,

I have exactly the same error. I think the latest launcher has the bug. Could you please try the following steps?

  1. Prepare a new Windows PC, a clean-installed Windows PC, or any PC with which Unreal Engine has not been installed yet.

  2. Install Unreal Engine (= Launcher) from UE's website. The current version is EpicGamesLauncherInstaller-2.12.25-3343384.msi (3. Install any version of Unreal Engine)

.uproject has not been associated to Unreal Engine, and cannot open either by double-clicking the .uproject or double-clicking the icon on My Projects of Launcher.

I clean-installed my PC twice but the above problem happened.

(comments are locked)
10|2000 characters needed characters left

Can you help me out please I'm lost as to where you're speaking about. If it's the C:\Program Files (x86)\Epic Games\ or the Program Files alone and what exactly did you copy Sir? Please help?

more ▼

answered Apr 02 '17 at 09:54 PM

avatar image

TonsTheGamer
1 1 3 5

(comments are locked)
10|2000 characters needed characters left

I have this same problem in version 4.18 is there any way to fix it?

more ▼

answered Mar 12 '18 at 06:49 PM

avatar image

SSombraxD
1 1 1

avatar image IlllIl Mar 13 '18 at 09:09 PM

Can confirm I had the same issue today after a fresh install of Windows. I was able to solve it with user "leighswift" his solution.

avatar image SSombraxD Mar 14 '18 at 12:31 AM

I understand perfectly the problem , is that I do not understand the user's solution that you mention maybe I'm making a mistake somewhere this error happened to me when formatting my windows 10 if you can provide a video or something would be great

(comments are locked)
10|2000 characters needed characters left

Find your project file alt text

Next, right click and choose the option to open with

alt text

make sure you go to program files, NOT program files (x86) click the ue4 editor

alt text

Hope this helps!

0.png (9.2 kB)
1.png (21.3 kB)
2.png (12.1 kB)
more ▼

answered Mar 13 '18 at 06:07 AM

avatar image

YourOwnPetRock
1

avatar image SSombraxD Mar 13 '18 at 05:36 PM

hello yes thank you very much I tried this myself the problem is that I can not run my project from the launcher

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question