x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Frontend and VS cause each other to rebuild-all Editor

This is new (to me) in 4.15. I didn't see this in 4.14.1.

I build the Editor in VS and then when I build a WindowsServer package using Frontend, it decides that the entire Editor project needs to be rebuilt. Then if I change a line in my project code and build it in VS, it thinks the Editor needs a full rebuild. Every time they conflict like this I have to rebuild all 490 items.

I didn't do anything I haven't done in 4.14.1 so I'm pretty sure it's not me.

I'm not hopeful but I thought I'd see if anyone had any ideas. For specific issues like this web-search is literally useless. Too many results for much simpler issues clog my results. That happens for 95% of my problems.

Product Version: UE 4.15
Tags:
more ▼

asked Mar 23 '17 at 09:39 PM in C++ Programming

avatar image

Jin_VE
4.4k 32 77 42

avatar image Jin_VE Mar 23 '17 at 09:41 PM

Could it be the new faster-compile header system? I haven't found any decent documentation on how to replace my old headers with the new ones. I heard old projects wouldn't even compile but mine doesn't get errors, it just always rebuilds from scratch if I compile the server in Frontend.

avatar image Jin_VE Apr 10 '17 at 08:59 PM

Can someone try upgrading a 4.14.1 multiplayer project to 4.15 and see if they get the same problem? This is making it very difficult to work on any project.

avatar image Jin_VE Apr 15 '17 at 03:16 AM

I updated my plugin and project to the 4.15 header changes. The Frontend still rebuilds the editor from scratch even though it was already built in VS. If I build it in VS again, it will also start from scratch. They are invalidating each others build. Why?

avatar image vlad.serbanescu11 Apr 20 '17 at 04:03 PM

I have the same issue and couldn't find a fix for it. My project is just an encapsulation for a plugin I'm developing (a blank C++ project without a single line changed). I've had this issue on 4.14, 4.15. and now on 4.15.1.

This page is literally the most info I was able to find. Has anyone found anything useful?

avatar image Jin_VE Apr 20 '17 at 08:02 PM

Well, we're both using custom plugins so that might be a clue.

avatar image vlad.serbanescu11 Apr 22 '17 at 12:44 AM

Maybe, indeed.

Have you checked to see if this problem occurs with a custom C++ project, but without any plugins? (I haven't, yet; will test after I release my plugin)

avatar image eXi May 06 '17 at 04:29 PM

Any news on this? It drives me crazy that I have to rebuild the Editor solution every time. Even the Server files shouldn't need that. I built DevelopmentServer and DevelopmentEditor in VS already. There should be no need for Frontend to do it again...

avatar image Jin_VE May 22 '17 at 07:17 PM

I asked a friend to try upgrading my project. He's using 4.15 and VS2017. He said he didn't see this issue. Perhaps the answer is to upgrade to 2017?

I'm pretty sure answering my own question won't get me points so if any of you would like to try this and post an answer if it works, please proceed. I'd prefer an answer on how to stay with 2015 but I'll take what I can get.

avatar image eXi May 22 '17 at 07:18 PM

Could be, I could try that. But it's still weird. Is UnrealFrontend using a diff compiler (VS2017 one)? I sadly don't know how exactly these things work.

avatar image vlad.serbanescu11 May 22 '17 at 07:30 PM

I've only been using VS2017 with 4.15 and still have this issue. On 4.14, I was using VS2015. Nothing's changed on my end.

avatar image Jin_VE May 22 '17 at 07:38 PM

Bummer. Stuck with using 4.14.1 or only using the frontend to build 4.15. Has anyone tried to upgrade to a 4.16 preview? Seen if it happens there too?

avatar image eXi May 22 '17 at 07:38 PM

Hmpf, well I opened my own bug report question about this some time ago, but haven't heard anything from Epic yet ):

avatar image Jin_VE May 22 '17 at 07:45 PM

Just a note. It hit me that the frontend needs the editor to be up to date so it can cook the server package. I think that's why it builds the editor first when it's out of date. We need to figure out why it thinks the editor is out of date, or even to tell it to ignore the editor & always make sure it's current ourselves.

avatar image eXi May 22 '17 at 07:49 PM

I tried to run UBT outside of Frontend, via command line. And it also rebuilt the Editor. Some check for the "up-to-date" version seems to fail.

avatar image Jin_VE May 23 '17 at 12:22 PM

Damn. This is killing me. I want to use more than 4.14.1 but I've fallen and I can't get up-graded.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Alright, I tried 4.15.3 and still hit this issue but it doesn't happen for me in 4.16. It looks like it's time to close out my question.

If you need to use 4.15 then the best way to avoid this issue is to build everything in VS. In the Frontend profile, turn off the "Build" command (checkbox on the right). You're building in VS and then cooking and packaging in Frontend. It works fine for me.

I'm going to mark this as the answer for the time being. Let me know if/when that should change.

more ▼

answered Jun 11 '17 at 03:44 PM

avatar image

Jin_VE
4.4k 32 77 42

avatar image Jin_VE Jun 23 '17 at 08:17 PM

Another tip: when you set a Frontend profile to build for Development/Shipping/etc., that setting is used even if the Build part of the profile is disabled.

So if you want to build for Shipping, you would enable the Build part, change it to build for Shipping, and then disable it again. Even though it is disabled, the Frontend will look for the Shipping build. Build that in VS first so it can be found.

avatar image Jin_VE Jun 23 '17 at 08:22 PM

And for the record, even though UE4 has reached 4.16 I still think bugs like this should be fixed for those who don't upgrade. 4.16 doesn't have this issue but it does have several bugs that prevent me from upgrading. It would be nice if fixes to big honking bugs in older versions were added to the older versions too.

avatar image Jin_VE Jul 19 '18 at 05:45 PM

This problem is back in 4.20. Submitting a bug report...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question