x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

"Scripting the Main Menu" UE4 Documentation -- Play Game not working correctly.

So I have been following the "Scripting the Main Menu" Documentation and everything works fine except for the Play Game button which loads my chosen level.

What occurs is that I play it in the editor, click the button and for a split second it appears to launch the map but then switches back to the menu.

Here are some screenshots of the relevant blueprints. They are identical to the ones used in the Documentation, so the issue must be elsewhere.

So I guess my question is where to start looking, because I was unable to find any solid suggestion with good old google!

alt text

alt text

Product Version: UE 4.12
Tags:
level blueprint.png (253.3 kB)
menu widget bp.png (334.6 kB)
more ▼

asked Mar 24 '17 at 01:30 AM in Blueprint Scripting

avatar image

KnightSirius
3 1 1

avatar image KnightSirius Mar 24 '17 at 03:13 AM

Just a quick update....

I guess the way I saw it working was this level load, could be in the same level it's loading which doesn't make much sense. Seems you have to have another level or else it will just open the menu again which is the issue I'm having and it makes sense.

However, I made a new level for the main menu... and implemented the exact BP Script as above; but it continues to simply load the menu after playing the level for a split second!

I must have some sort of logic error, but have no clue what it could be!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

`When you click play ,the event begin play its called and its working like a loop. You need to create a level only for the main menu and when click play take it to other level.

more ▼

answered Mar 24 '17 at 07:27 PM

avatar image

Tzaks
65 6 6 11

avatar image KnightSirius Mar 25 '17 at 12:46 AM

That was definitely what worked!

However I did figure that out myself and I commented it above last night. (You may have missed it)

What is strange is yesterday it was NOT working at all, even with the separate menu level. I would click play and it would just open the level for a second and go back the the menu.

Though today I just tried it again (for my minds sake, before commenting) and it worked! Maybe it was the computer being restarted (I had restarted Unreal a few times to test it), so this could be a small bug.

Thanks for the response though! What you suggested technically was the fix! :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question