x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

FBX Import Material Problem After 4.0.2

We started a project back in version 4.0.2. The project consists of buildings with lots of pieces that were very easily managed by importing them as a combines mesh with materials. The files came in with placeholder materials that made it a breeze to assign our Unreal shaders and we were all happy and went home on time to see our families.

We upgraded to 4.2.1 and were happy with all the improvements...until we had some new FBX assets to import. Something changed with the FBX import. From my testing with 4.0.2, 4.1, 4.2.1, the same FBX imports differently for versions after 4.0.2 It brings in all the materials, but loses some of the assignments.

So an asset that came in with 7 unique material objects in 4.0.2 comes in with only 3 in later versions of the engine. There are no errors or obvious reasons for the change, but it is a huge issue for our project. Please let me know if this is a known issue and if there are any chances of this getting fixed.

I have attached a file the illustrates the issue I am having between Unreal Editor Versions. The attached file has been messed up a bit on purpose as the assets are for a real project. But the issue occurs with the clean version of the models. Just import as a Static Combined Mesh with Materials. When imported in 4.0.2 you will see 8 Elements make up the model in the Static Mesh Editor. In the later versions of Unreal Engine there will only be 3 Elements in the making up the asset.

The export settings from Maya have no effect on the issue (FBX2013 or FBX2014)

Thanks so much for any help

~Ben

[1]: /storage/temp/8724-vf01_export.zip

Product Version: Not Selected
Tags:
vf01_export.zip (497.7 kB)
more ▼

asked Jun 18 '14 at 02:03 PM in Bug Reports

avatar image

animatedfox
6 2 4 7

avatar image Tim Hobson ♦♦ STAFF Jun 18 '14 at 06:51 PM

Hi AnimatedFox,

I've created a Multi-sub-object in 3Ds Max 2013 and imported it into 4.02, 4.1.1, 4.2.1, and our internal build of 4.3 with no issues. I've created a cube with six material elements. I embedded those within the FBX and imported that into the engine with no issues. The materials were created and assigned appropriately.

Do you have a test asset you can recreate this on a test asset that I can open in 3Ds Max and then import and see this happen? Also, is this only happening with the project you are working on, in any examples or templates we provide, or even a newly created project?

Any detailed information for this would be helpful in trying to isolate the issue.

Thank you!

Tim

avatar image animatedfox Jun 18 '14 at 07:23 PM

I have a file attached to this thread that illustrates the issue. I had the same results that you did when trying to recreate the issue with a simplified setup.

No problems are more annoying than the ones that are hard to recreate. I blame our assets completely, but the frustrating part is that they DO work wonderfully with 4.0.2. I have no idea where to start with rebuilding the assets to work with the newer versions.

Give the attached file a try to see if you get the same results. I get the issue with some(not all) of the muti-object FBXs for this project...and I get the same results when importing them into a clean project.

I really appreciate you taking the time to look into this issue. ~Ben

avatar image Tim Hobson ♦♦ STAFF Jun 18 '14 at 07:54 PM

Hi Ben,

I definitely don't mind looking into this. I don't think the file attached here on the comment. Could you re-upload that and I'll take a look. :)

Thank you!

Tim

avatar image animatedfox Jun 18 '14 at 08:00 PM

Sorry, when I said 'this thread' I meant the original post. It is at the bottom. You are the BEST!

avatar image Tim Hobson ♦♦ STAFF Jun 18 '14 at 08:02 PM

OH! Didn't even see that before! Thanks! :)

avatar image Tim Hobson ♦♦ STAFF Jun 18 '14 at 08:42 PM

Hi Ben,

This is a work around at the moment, but what I just did worked. I loaded up the mesh in 4.0.2 where it sees the 8 materials. I exported it from there to an FBX. I then imported that into 4.2.1 and it now sees the 8 material slots.

I know this doesn't fix the issues but it's a workaround for the moment while I look into this. If I don't see the issue in our bug reporting software I'll submit one for this, but I need to see if I can get a good repro for it before I can.

Let me know if this work around works for you as well!

Thank you!

Tim

avatar image animatedfox Jun 18 '14 at 08:56 PM

Tim, Thanks so much for this suggestion. It is good to know that the functionality exists. We would definitely need to figure out a way to do this in batches...which might be a bit of a time sink as we have a lot of assets. But if it makes the scenes more manageable in the end it would be worth it.

I tried the same kind of test you did to reproduce the error, but found no simple build that reproduced the results. For what its worth, the FBX I posted can be imported into Maya correctly and re-exported with the same results. I want to re-state that I know the actual mesh is a total mess...but I needed to mess it up to get approval to post it. I assure you that the meshes generating these errors are clean and throw no errors on importing to Unreal.

Thanks again for your time. We really appreciate any progress that you can make on this issue. ~Ben

avatar image Tim Hobson ♦♦ STAFF Jun 18 '14 at 09:03 PM

No problem!

I was just able to replicate this issue fresh with the HeroTPP character asset from the Third Person Template. I exported it to 3Ds Max and separated the different appendages into their own objects. Applied separate materials to each and then exported. I imported into 4.0.2 with no issue. DLing 4.1.1 now to see what happen there. In 4.2 and our internal build of 4.3 the issue persists.

Tim

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Ben,

I just got confirmation that this is being fixed now and should be in 4.3's release soon. I don't have a firm date for 4.3, but it's on par with our normal spacing between engine releases. If you are still having issues after the release of 4.3 please comment back here and I'll pass this along to be looked at.

I do apologize you have to work around the issue for the moment.

Thank you for the great information and detailing to get this fixed!

Tim

more ▼

answered Jun 18 '14 at 10:27 PM

avatar image

Tim Hobson ♦♦ STAFF
49k 886 99 875

avatar image animatedfox Jun 19 '14 at 01:03 PM

Thank you so much for looking into this issue and getting it fixed for the next version! Really impressive how quickly you were able to replicate the issue and get a fix worked out. I wrote a script to combine the meshes by material in Maya before exporting and that seems to work for the meshes I tried so far in 4.2.1. So instead of 50 objects divided up by 5 materials for Unreal to sort out, I am exporting 5 merged objects with 5 materials. It seems like they are happy...so I am happy. But the fix will be appreciated.

Again, thank you so much for addressing this issue. I will be sure to grab 4.3 as soon as it is out. ~Ben

avatar image Tim Hobson ♦♦ STAFF Jun 19 '14 at 05:19 PM

No problem at all!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question