x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Fatal error: [File:D:\Build\++UE4+Release-4.15+Compile\Sync\Engine\Source\Runtime\Engine\Private\GlobalShader.cpp] [Line: 353] Missing global shader FPixelShaderDeclaration, Please make sure cooking was successful.

Had this in 4.13. Updated to 4.15. Still occuring.

Reproduction:

Environment: Windows 10 SteamVR with HTC Vive installed

Steps:

Launch Unreal Engine 4.15.1

New Blueprint Project - Blank

Desktop/Console, Max Quality, No starter content

Create Project

Edit > Plugins > Virtual Reality

Disable all selected (Gear VR, Oculus Input, Oculus Library, Oculus Rift, SteamVR)

Restart Now

Close plugin page

Click "Launch" button

Save map

Wait for launch...

Error dialog opens containing:

Fatal error: [File:D:\Build\++UE4+Release-4.15+Compile\Sync\Engine\Source\Runtime\Engine\Private\GlobalShader.cpp] [Line: 353] Missing global shader FPixelShaderDeclaration, Please make sure cooking was successful.

Product Version: UE 4.15
Tags:
more ▼

asked Mar 25 '17 at 01:02 AM in Packaging & Deployment

avatar image

Rowbow
11 1 2 3

avatar image Danisme1 Apr 19 '17 at 07:21 PM

Did you find a fix for this?

avatar image Brainshack Apr 27 '17 at 03:03 AM

For me activating the VR Plugins seem to have fixed it.

avatar image Rowbow Apr 27 '17 at 03:07 AM

The defect is that VR is required to launch. I have an HTC Vive causing steamvr and my lighthouses to go active despite a non-vr game.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

I also had this issue, so I had to fix it myself. This is the fix:

Go to HeadMountedDisplayCommon.h and there you see 3

 #define OCULUS_STRESS_TESTS_ENABLED

Make sure that everyone of those is set to

 #define OCULUS_STRESS_TESTS_ENABLED 0

Then package again, and it's fixed :)

more ▼

answered Aug 16 '17 at 04:00 PM

avatar image

John Alcatraz
1.3k 58 139 127

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello Rowbow,

Thank you for submitting a bug report. I have reproduced this issue and logged a report for it here

https://issues.unrealengine.com/issue/UE-43383

You can track the report's status as the issue is reviewed by our development staff. Please be aware that this issue may not be prioritized or fixed soon.

more ▼

answered Mar 27 '17 at 09:16 PM

avatar image

Thomas G ♦♦ STAFF
7k 64 4 54

avatar image Blue669 Aug 10 '17 at 06:50 AM

This issue has not been fixed in 4.17 as described in the Bugtracker. I just had exactly this issue with my packaged build and re-enabling the VR Plugins fixed the crash.

avatar image Matthew J Aug 10 '17 at 03:16 PM

Hello Blue669,

Thank you for reporting that this issue still occurs. I've tested it locally and reproduced it on 4.17 release myself. As such, I've reopened the ticket and we will be looking into a solution. It's possible that this only happens in the Binary editor. If that is the case, that would explain why it seemed to be fixed at the time.

avatar image Alex Forsythe Aug 14 '17 at 02:36 AM

Hey Matthew, I just wanted to chime in and let you know that I'm experiencing this same issue. I made another AnswerHub post to inquire about UE-43383, which at the time seemed to have been mistakenly flagged fixed in a mysterious nonexistent changelist: https://answers.unrealengine.com/questions/666305/once-an-issue-is-marked-fixed-in-the-issue-tracker.html

The issue started occurring for me once the SteamVR plugin was explicitly disabled. Prior to that change, the .uproject file didn't contain a reference to SteamVR in its list of plugins (meaning it was enabled by default), and the standalone Win64 game executable (built in Development Client config) worked fine. Once SteamVR was explicitly disabled in the .uproject file, and then all executables rebuilt and content re-cooked, the same game executable crashes on startup with the error shown above in Rowbow's original post.

If I'm understanding "in the Binary editor" correctly (i.e. if you mean that the issue might only occur with the precompiled Launcher version of the engine, and not with local editor binaries compiled from source), then I wanted to mention that I'm seeing this issue when using a build of UE 4.15 that I've cloned from GitHub and built from source.

avatar image 6r0m Nov 07 '17 at 02:33 PM

confirm that 4.17, I can't start packaged game without OCULUS VR PLUGIN no needen in my game

avatar image brennanjviii Jun 20 '18 at 02:13 PM

I am getting the same issue. First time seeing it and now it is happening all the time. LowLevelfatalError [file:D:\Build++UE4+Release-4.16+Compile\Sync\engine\sourse\runtime\renderCore\Private\RenderingThread.cpp}{Line:981}…

I'm using the windows mixed reality. It worked fine for several months. Must have something to do with an update somewhere. Like SteamVR.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

[File:D:\Build++UE4+Release-4.19+Compile\Sync\Engine\Source\Runtime\ApplicationCore\Private\Windows\WindowsWindow.cpp

more ▼

answered Jul 17 '18 at 06:39 PM

avatar image

irapocy
1 1

avatar image irapocy Jul 17 '18 at 06:39 PM

[File:D:\Build++UE4+Release-4.19+Compile\Sync\Engine\Source\Runtime\ApplicationCore\Private\Windows\WindowsWindow.cpp

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

is it the same or other?

cant fix it... cant play...

LowLevelFatalError [File:D:\Build\++UE4+Release-4.19+Compile\Sync\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Query.cpp][Line: 111] GPU has crashed

more ▼

answered Sep 03 '18 at 05:11 PM

avatar image

BlackEagle2k18
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question