Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cannot nativize my Character due to Tutorial_BP_Interface ?


I just upgraded my project to 4.15.1 and normal packaging works fine, however, I wanted to use the exclusive nativization feature for my character blueprint. It's currently the only blueprint I am nativizing because it's the heaviest and I wanted to test and see that it works.

However I am getting an error when packaging the project:

 LogBlueprintCodeGen:Error: BP /Game/Stardrop/Characters/Player/SD_PlayerCharacter.SD_PlayerCharacter is selected for nativization, but BP interface class /Engine/Tutorial/BlueprintTutorials/TutorialAssets/Tutorial_BP_Interface.Tutorial_BP_Interface_C is not

So, I'm guessing somehow somewhere the Tutorial_BP_Interface is referenced somewhere but I have no clue where. I started this project I think way back on 4.7 as a third person blueprint.

I was hoping someone could shed some light on how to either remove this, or include it into the nativization process or any other means to get me to package my game. Because this is an engine content I cannot select it to be nativized when packaging.

Any help would be greatly appreciated.

Product Version: UE 4.15
more ▼

asked Mar 25 '17 at 05:27 PM in Packaging & Deployment

avatar image

60 3 7 10

avatar image Sean L ♦♦ STAFF Mar 27 '17 at 02:30 PM

Hey Joure,

If you navigate to your character's Class Settings inside of the blueprint, do you have any implemented interfaces at all?

Are you having this same issue if you try to nativize a character blueprint in a clean project? I wasn't seeing it on my end when I tested.


avatar image Sean L ♦♦ STAFF Mar 30 '17 at 04:50 PM


I am marking this topic as resolved for tracking purposes, as we have not heard from you in a few days. If this issue persists, feel free to respond to this thread. For any new issues, please create a new Answerhub topic.

Have a great day

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Sorry for the late reply. I'm not sure how but it seems that somehow this issue got carried over from updating the project over time. The strange thing was that I never used the asset anywhere within my blueprint.

The solution for me was to simply delete Tutorial_BP_Interface from within my engine content.

All I needed to do after that was to simply compile it one more time and did so without any warnings. The reference was gone. As I don't have a use for it I just tried to do it that way and I no longer get the error.

I am still dealing with errors but is unrelated to this one. It was a bit of a crude fix but hey, sometimes you gotta go that route.

more ▼

answered Apr 01 '17 at 11:28 AM

avatar image

60 3 7 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

If you right click on the Tutorial_BP_Interface icon in the content browser you can bring up a reference viewer that shows which other assets reference this blueprint. Sadly, in a freshly created project nothing relevant shows up, but hopefully you'll be able to see the offending reference in your project.

reference viewer

The obvious thing to do is, of course, to check the class settings of the Blueprint you are trying to nativize and check whether the interface appears in the Interfaces pane. That would be the easiest solution, but probably you're not so lucky to have a direct reference. :)

more ▼

answered Mar 26 '17 at 11:16 AM

avatar image

Matthias Hölzl
416 13 6 19

avatar image Joure Mar 26 '17 at 11:34 AM

Thanks for suggesting this. I actually tried the reference viewer as well but it just shows a direct reference to the character blueprint.

I also tried to exclude the Tutorial_BP_Interface using the DefaultEditor.ini but that doesn't seem to help.

And something else that perplexes me is that even if I don't add my character blueprint, and choose another blueprint actor to be nativized, it still results in the same error.

So I'm really confused why it wants to nativize the Tutorial_BP_Interface so badly, even when it's not directly referenced.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question