x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Root Motion Translation Scale

Hello, usually i can find a solution to my problem if i look online enough but ive been searching for a while now and i can seem to find anything.

when i import my model and animations everything works as intended, however when i apply root motion to my animation the movement scale seems to shrink.


Without Root Motion Enabled: https://gyazo.com/b42cf85cceea5baf0f4f94ad2f7545d7

With Root Motion Enabled: https://gyazo.com/1c87061a69b4411694cdd8e93512f46b


I have tried importing into Unreal 4.15 but ran into the same issue. I'm not sure how to fix this, is there a way to scale up the root motion translation?

Thank you for your time ^^

Product Version: UE 4.14
Tags:
more ▼

asked Mar 27 '17 at 02:43 AM in Using UE4

avatar image

MiniTigress
3 2 3 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I found that my joint sizes in Maya needed to be set to 1, changed up my rig and now root motion is working properly.

My mistake was probably scaling up the FBX file before importing it into Unreal which messed up the root motion translation.

more ▼

answered Mar 27 '17 at 12:30 PM

avatar image

MiniTigress
3 2 3 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

So, I just had this issue, going to spread how I solved it, as it may not work for all but might help some.

There is a non blueprint exposed function in character.h called SetAnimRootMotionTranslationScale() . I went in and exposed it to blueprints and then can just set it to compensate for whatever the scaling issue is (mine was 100). Not sure why this is not exposed to blueprints by default... but yeah, if your using C++ you can just call that function, or if you want to build your own engine from source you can expose it to blueprints yourself.

more ▼

answered Oct 10 '17 at 05:17 AM

avatar image

Ostoril
16 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question