x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Map with media texture not packaging

I have a simple map with a Big-sphere and a pawn inside it. I use media texture and media player to play 360 video on it. But when I try to package it for windows-64 it fails while it tries to cook the map.

Yes all the videos are copied to Content/Movies first and then imported to UEProject as asset later.

This is very crucial to our project. One of our developer have already started to build the solution in Unity just in case if packaging issue does not resolve with media player in unreal.

Please help!

Product Version: UE 4.15
Tags:
more ▼

asked Mar 27 '17 at 11:51 AM in Packaging & Deployment

avatar image

himanshu810e
1 1 2 4

avatar image AndrewHurley Mar 27 '17 at 01:03 PM

Hey himanshu810e,

The best way to figure out why your packaging is failing is to provide me with the logs of your most recent failed attempt. Look for anything that says 'Error' and use google to put all or parts of that error in quotes to help you search for any common or known issues.

I am assuming you are using the project I provided as a test case, but I would also need a way to reproduce the issue on my end. Therefore, if you can provide screenshots and steps on how to reproduce your issue, that would be most beneficial.

Thanks,

Andrew H

avatar image himanshu810e Mar 27 '17 at 01:14 PM

Hi Andrew

Thanks for responding :). Here is what I got in the error when I tried to package the project you have shared for windows-64(I did opened it on 4.14).

link text

log.txt (5.2 kB)
avatar image AndrewHurley Mar 27 '17 at 02:14 PM

Notice in your log it says "UnrealBuildTool: LINK : fatal error LNK1181: cannot open input file 'C:\Program Files (x86)\Epic Games\4.14\Engine\Plugins\Marketplace\AllrightRig\Binaries\Win64\UE4-ARigRuntime.lib'"

It appears you have a plugin that is either incompatible with the version of your engine, or it is just causing problems when trying to package. I would take a look at this plugin for starters.

Let me know if you have further questions.

Thank you,

Andrew Hurley

avatar image himanshu810e Mar 27 '17 at 03:04 PM

Ah I see. That was the plugin issue. I was able to package your sample successfully.

Now when I try to package my actual project I get error while cooking (see attachment). The only thing I am doing different than the sample project is that I am getting my MediaSource from my GameInstance class as the level plyaing my 360 video is being opened from another level and based on user selection I play the respective video.link text

log-2.txt (5.8 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

That could be your issue then. I would handle it within a self contained blueprint like my example project, so it is not dependent on an game instance, just if the blueprint exists in the current level.

Also, I am not sure how you are implementing a 360 video, but that sounds like something that might require the Ansel plugin or something of the like in order to have it playback correctly.

Since you were able to packaged my project successfully, this does not seem like a bug with the engine, but rather your own setup. You will need to run through your logs and fix your errors. Read the messages as they usually tell you exactly what the issue is and where it can be found.

For example in the logs you just provided: "LogSavePackage:Warning: Obj in another map: videoMapbkup_C /Game/Maps/videoMapbkup.videoMapbkup:PersistentLevel.videoMapbkup_C_0"

This definitely means it cannot find the video because it is in a different level than the one that is currently loaded and calling the video to play.

Thank you,

Andrew Hurley

more ▼

answered Mar 27 '17 at 04:44 PM

avatar image himanshu810e Mar 27 '17 at 05:18 PM

Hi All

@AndrewHurley : Thank you so much with the troubleshooting. we got it fixed YAAAAAY!

I got my problem fixed by comparing my video playing logic to yours. The finding is that do not try to play video from level blueprint itself. Let the component play the video.

avatar image AndrewHurley Mar 27 '17 at 05:23 PM

No problem! Glad I could guide you in the right direction. As I mentioned, sometimes you just need to slowly read the output log and understand what the error message is telling you. More often than not, it will point you to a directory or specific file.

Cheers,

Andrew H.

avatar image himanshu810e Mar 27 '17 at 07:42 PM

Well technically the error message was talking about missing object which is not hinting whatsoever that instead of using media player from level blueprint use it inside a blueprint actor. I think this should be the part of media player fw documentation.

avatar image DesertEagle_PWN Apr 12 '19 at 04:00 AM

@AndrewHurley I agree with @himanshu810e.

I ran into this same (followup) issue (same "warning" followed by same fatal error, nearly identical output log), but I am not trying to load a media source stored in reference outside the level. I only have one level in my project which just has a "VideoPlayer" blueprint and a PlayerStart.

In my Video Player BP I have a MediaPlayer reference with the default value assigned to a MediaPlayer created within the editor (content browser right-click). Whenever I try and implement an OnMediaOpened callback event for that MediaPlayer .uasset my packaging fails with that same error (log attached) and it is very unclear what causes the failure. More transparency would be greatly appreciated in these cases.

I'm still not able to cook if I implement any callbacks from the media player reference while its default value is set.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Thanks @FreshStaticSnow. I neglected to mention in my response that the workaround is to remove the default value for the MediaPlayer variable and then assign it at runtime using BP nodes.

more ▼

answered Jun 03 '19 at 08:07 PM

avatar image

DesertEagle_PWN
187 10 26 25

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi, this problem was driving me nuts but after reading this thread & another thread from google I figured it out:

Put your media player variable in the game instance and control it by casting to the game instance in level/actor/whatever BPs

more ▼

answered Jun 03 '19 at 04:46 PM

avatar image

FreshStaticSnow
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question