x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

No sessions found with Steam (4.15.1)

There seems to not be any sessions returned when searching using the Steam subsystem. The sessions is created successfully and in the delegate I open a map with '?listen'. When I search locally for sessions find sessions returns no results (should this never find my own session?), and when a friend searches for sessions they also do not find any.

My sessions settings and search settings are as follows:

Session Settings

     NumPublicConnections = 5;
     NumPrivateConnections = 0;
     bIsLANMatch = false;
     bShouldAdvertise = true;
     bAllowJoinInProgress = true;
     bAllowInvites = true;
     bUsesPresence = true;
     bAllowJoinViaPresence = true;
     bAllowJoinViaPresenceFriendsOnly = false;

Search Settings

     bIsLanQuery = false;
     MaxSearchResults = 10;
     PingBucketSize = 50;
 
     QuerySettings.Set(SEARCH_PRESENCE, true, EOnlineComparisonOp::Equals);

In both cases the SEARCH_SETTINGS settings is being set to a constant and both are set to the same thing elsewhere.

Product Version: UE 4.15
Tags:
more ▼

asked Mar 27 '17 at 05:03 PM in C++ Programming

avatar image

S0rn0
71 8 13 12

avatar image S0rn0 Mar 29 '17 at 05:30 AM

Here are the UE logs

 LogOnline:Display: STEAM: Loading Steam SDK 1.32LogStreaming:Display: Async Loading initialized: New Async IO: true, Event Driven Loader: true, Async Loading Thread: false
 LogInit:Display: Starting Game.LogOnline:Warning: OnCreateSessionComplete : Game - bSuccess: 1
 LogOnline:Warning: OnCreateSessionComplete : Game - bSuccess: 1LogOnline:Warning: Async task 'FOnlineAsyncTaskSteamFindLobbies bWasSuccessful: 0 NumResults: 1' failed in 15.016780 seconds
 LogOnline:Warning: Async task 'FOnlineAsyncTaskSteamFindLobbies bWasSuccessful: 0 NumResults: 1' failed in 15.016780 secondsLogOnline:Warning: OnFindSessionsComplete bSuccess: 0
 LogOnline:Warning: OnFindSessionsComplete bSuccess: 0LogOnline:Warning: Num Search Results: 0
 LogOnline:Warning: Num Search Results: 0LogWindowsTextInputMethodSystem:Display: IME system now deactivated.
avatar image caelanim8ter Apr 01 '17 at 12:41 AM

Bump, I am running into the exact same issue. No Session found with dedicated servers

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question