x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Successfully built lightmaps turn black after editor restart

Hello :-)

Our team is working on a large map filled with a very high number of static meshes (each one of the ~90 building blueprints consist of several modular pieces). Apart from minor lighting issues that were fixed relatively quick the lightmap build worked out quite good. The whole project was saved.

But when we opened up the editor the next time, some of the static meshes that were fine just hours ago have turned completely black. A lighting rebuild fixed the black meshes until we restarted the editor, then the same meshes were black again. Building the light and immediately packaging the project for windows 64bit didn´t solve the issue either, the meshes turned black again.

Here is a picture showing some of the black meshes: alt text

We assume there is a problem in how Unreal stores the lightmaps, but we are not 100% sure. Maybe the reason for the problem is to be found on our side. Either way, any help would be appreciated ;-)

Product Version: UE 4.14
Tags:
lightmapbug.png (1.3 MB)
more ▼

asked Mar 27 '17 at 07:48 PM in Bug Reports

avatar image

Donot97
3 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey Donot97,

So the first thing I would suggest is merging all of those modular roof pieces as one actor to see if that resolves your issue. Especially since they combine to make an entire section of roofing.

You can use the console command 'DumpUnbuiltLightInteractions' to see what is left unbuilt after you re-open your project. The best advice I can give you with the information you have provided is to take a look at another user's post who was reporting a similar issue.

https://answers.unrealengine.com/questions/468304/lightmap-problem-after-reopen-project.html

Let me know if you have additional questions after troubleshooting more and following the suggestions in this post and the one provided in the link.

Thank you,

Andrew Hurley

more ▼

answered Mar 29 '17 at 04:18 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Sorry that it took me so long to respond, but it seems that merging the actors together solved the problem! Thank you very much :-)

more ▼

answered May 01 '17 at 07:12 AM

avatar image

Donot97
3 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question