x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Stationary Lights not reaching the Overllap Limit, but Red Cross sign appearing

Hi, we've been receiving the Red Cross sign indicating that more than 4 stationary lights are overlapping, although, there is only 2 of them, or setup looks like this:

  • A Stationary Directional Light: the sun

  • Stationary Torchs: those are used sporadically with a very limited range, since we got a plenty of light from the sun already.

So, i'm guessing that we get a max of 2 stationary lights overlapping only, but all of ours directional lights becomes red-crossed after restarting the editor.

So my question is: it is normal to have red-crossed stationary signs even when the limit of 4 stationary overlapping is not reach?

I'm attaching two images from a same spot, one of with the "Stationary Light Overlap" optimization view mode enabled:

alt text alt text

Thanks in advance.

Product Version: UE 4.15
Tags:
more ▼

asked Mar 28 '17 at 12:55 AM in Using UE4

avatar image

Animaxe
13 1 3 6

avatar image Animaxe Apr 08 '17 at 06:59 PM

Bump. Any help would be great, thanks.

avatar image Animaxe Apr 24 '17 at 09:44 AM

Sorry for bumping it again, i really could use some help here, thanks in advance.

avatar image Animaxe May 24 '17 at 09:11 PM

Bump once more.

avatar image Animaxe Sep 28 '17 at 11:05 PM

Besides the fact the preview seems to be not always correct, everything is working fine, i can see the performance gain after light builds.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I ran into what sounds like the same problem today. In my case it had to do with Blueprint hierarchy. The stationary light (a spotlight) was linked under a theoretically moveable actor (in this case, a point light which I didn't intend to move, but apparently it fits the bill). By using "cut" to remove the spotlight from its linked position under the point light (for some reason you can't drag and drop), then selecting the topmost master node and pasting it back in, it re-appeared linked directly to the master and began to work.

Hope that helps.

more ▼

answered Jun 12 '17 at 08:15 PM

avatar image

Blacklake
1 1 1

avatar image Blacklake Jun 12 '17 at 08:18 PM

To clarify, this BP structure didn't work::

DefaultSceneRoot

_Pointlight (static)

__Spotlight (stationary)

This one did:

DefaultSceneRoot

_Pointlight (Static)

_Spotlight (Stationary)

avatar image Animaxe Jul 10 '17 at 08:56 PM

Thanks for your reply. I've thought this could cause problems before, so all lights are manually placed on the world directly (not inside any blueprints).

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question