x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

No ground box collision in PhaT

I have been having an issue for a while where nothing collides with the ground box inside the Physics Asset Tool. It seems to be localised just to my current project but it affects all Physics Assets.

Any asset I import including migrating from starter projects and even the Physics Assets in the engine content have the same behaviour, however if I create a new project I have no issue and all Physics assets including custom imports of my own behave properly. This only happens in PhaT outside of that tool everything works as intended but it makes it hard to get the collision boxes right. If I am quick or I turn gravity off I am able to grab the object with Ctrl-RightMouse but it still does not interact with the ground box.

It seems likely that this is something that I have done accidently at some point but not sure how or when, I have looked through the Project Settings and everything in Collision and Physics seems to be set to default except for a few custom object channels that I have created none of which are applied.

If someone has encountered something similar or if I'm missing something obvious a point in the right direction would be greatly appreciated.

Product Version: UE 4.15
Tags:
more ▼

asked Mar 29 '17 at 04:32 AM in Using UE4

avatar image

Ruffhaus Games
663 13 9 23

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Fixed in 4.16

more ▼

answered May 29 '17 at 11:17 PM

avatar image

Ruffhaus Games
663 13 9 23

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi, Bizmark

I came across the same issue as you. Just no ground box collision in PhaT and affects all projects created by this editor. I suspect maybe there is something wrong with the import settings or editor settings. Could you please tell me how did you fix this except updating the engine version or maybe more info about this issue?

Thank you very much.

Chen

more ▼

answered Oct 05 '17 at 06:19 PM

avatar image

YuchenMei
1 3 6

avatar image Ruffhaus Games Feb 22 '18 at 03:08 AM

I'm sorry the engine update was the only fix I had for it. I didn't look into it after that, as my problem had been fixed. Hopefully you found a solution.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question