x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Change version with 4.14.3 on 4.15.1

https://drive.google.com/file/d/0B1DWeiM0NqbUbEpDdHNsMC1FVjg/view?usp=sharing Help!

Running S:/Epic Games/UE_4.15/Engine/Binaries/DotNET/UnrealBuildTool.exe Lineage2UE4 Development Win64 -project="C:/Users/Reiner Lute/Documents/Unreal Projects/Lineage2UE4 4.14/Lineage2UE4.uproject" -editorrecompile -progress -NoHotReloadFromIDE Performing full C++ include scan (building a new target) Creating makefile for Lineage2UE4 (no existing makefile) @progress push 5% ERROR: In C:\Users\Reiner Lute\Documents\Unreal Projects\Lineage2UE4 4.14\Source\Lineage2UE4\Faction\CharacterAI.cpp: #include "BehaviorTree\BehaviorTree.h" contains backslashes ('\'), please use forward slashes ('/') instead.

Product Version: UE 4.15
Tags:
more ▼

asked Mar 29 '17 at 01:08 PM in Using UE4

avatar image

TPAKC
21 1 3 4

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hey TPAKC-

In the second video of your comment, it appears you did not actually compile the changes after deleting the contents of the file. If you open the solution you should be able to right click on the project name and select the Build option to compile everything. The editor should be able to open after this. If this compile fails, please provide the output errors for additional info. Additionally, if you right click on the .uproject file you should have an option to "Switch Unreal Engine version". You should be able to select this and manually switch the engine version from 4.14 to 4.15.

Cheers

Doug Wilson

more ▼

answered Mar 29 '17 at 07:56 PM

avatar image TPAKC Mar 29 '17 at 09:00 PM
avatar image Furinyx Mar 30 '17 at 12:56 AM

In your first video, the error from halfway point to end of video is saying the enum is trying to use an unsupported type, that is because of a typo you made. Your code shows the enum as:

 UENUM(BlueprintType)
 enum class EFactionType : unit8

but it should be:

 UENUM(BlueprintType)
 enum class EFactionType : uint8

where you accidentally spelt uint8 as unit8.

Other errors you see can be caused by the first initial errors so ignore other errors and focus on the first errors that show up. The "OtherCompilationError(5)" and "-waitmutex" errors are just related to UE4 failing to compile due to your code errors so you can ignore those.

Use build instead of rebuild. If you want to build cleanly, especially after removing files, make sure to choose 'Clean' so that it cleans up intermediate files and then choose 'Build'; you should find it then won't be attempting to still use files you have removed from source.

Deleting all source files won't work as UE4 can't build without the specific base project files which are needed needed. Until you clean the build, you will likely still have intermediate files trying to reference files you have deleted as well. Those errors after deleting the 'Source' folder in your second video are due to having zero project source (as you deleted the base source files created by UE4 for the project which it needs for knowing how to setup your project and specific UE4 data).

Other errors: In CharacterAI.cpp the OnSeePawn function has:

 if (NeuralFactions.Contains(Player->GetFaction())

where you have a typo of NeuralFactions instead of NeutralFactions.

In Header1.h, at the start of the class declaration you have: GENERATET_BODY() which should be GENERATED_BODY().

avatar image TPAKC Mar 30 '17 at 07:17 AM
avatar image Furinyx Mar 30 '17 at 11:46 AM

I missed that typo - class USptingArmComponent* in Header1.h should be class USpringArmComponent* .

You got errors half-way through the video when you removed the USpringArmComponent property because you left the "UPROPERTY(" line which needs a variable declaration to go with it (also take out the UPROPERTY line that is after the comment /**.Follow Camera */).

The function ACharacterAI::OnSeePawn(APawn* Pawn) error:

 AControllerAICharacter* Controller = Cast<AControllerAiCharacter>GetController());

should be:

 AControllerAICharacter* Controller = Cast<AControllerAiCharacter>(GetController());

Errors that have a Code starting with "LNK" mean they are linker errors instead of compile errors. This means after compiling, trying to link code to other code did not work. Trying to double click on these will not take you to the place of cause as the errors are located in the compiled obj files. A linker error generally happens when you are including a header file without cpp implementation (generally the cause is a function that hasn't been defined in the cpp file but is declared in the header file).

The error at the end of the first video was likely the fact you removed the OnSeePawn function from ACharacterAI in the cpp file but the function declaration still existed in the header file.

I'm sorry to say but this is very much a lack of ability to understand basic programming to be able to notice and resolve typo errors. I will try and help you get this build going but I really don't see you being able to continue writing code for UE4 without first doing structured learning if you cannot detect and solve these kinds of problems yourself (as all programmers end up with much harder errors they have to deal with as their project grows).

If this is not your code and is someone else's code that you copy-pasted or got from a plugin, you should ask them to fix their errors if you are finding any errors being stated in their source files by UE4 or Visual Studio.

avatar image Furinyx Mar 30 '17 at 12:30 PM

Another line that will likely cause an error:

 if (Controller && Player == Pawn && (Player->GetActorLocation()) - GetActorLocation()).Size() < 300.f)

should be:

 if (Controller != NULL && Player == Pawn && ((Player->GetActorLocation() - GetActorLocation().Size()) < 300.f))
avatar image Furinyx Mar 30 '17 at 12:07 PM

In response to your second question and video there - to start with, if you are making a C++ project it is best to choose the C++ templates tab when creating it rather than the Blueprint templates.

Moving UE4 files from "Content" by copy-paste can have issues so it is generally best to use the Migrate feature via the UE4 Editor instead (although you have to be in the project they are from to be able to migrate them to another project's content folder). Using source control would avoid this issue if you have something break that you cannot resolve as you can revert to an older build that worked and migrate files from that build.

The reason for your project working through creating a new project is because you did not copy over the C++ files that were giving you errors in the original project.

Simply creating a new project for a different version will not resolve version difference issues, if there are any. Also, especially so with larger projects, a lot of settings specific to a project are done via the Editor which can become time-consuming to ensure you transfer settings and default values over 1:1 between projects without missing something. If neither of those bother you then creating a new project instead is completely fine, just understand that in most cases the errors on switching version is due to your own errors so transferring over any files that include errors will result in the same result you were having with the original project.

avatar image TPAKC Mar 30 '17 at 12:45 PM

I'm doing my project in the blueprint. I learn to do C ++ on this video https://www.youtube.com/watch?v=jRxHp4EEqbs&t=159s, but I did not succeed and I decided not to use this method. After that I made a long time project on the blueprint. But now it's time to upgrade to a newer version. And at this moment there is this problem. Could you join my computer with the help of a teamviewer and help me solve my problem? Or are there other options?

avatar image Furinyx Mar 30 '17 at 01:05 PM

Can you get discord? You can screenshare on that and I'll walk you through it. Message me your username for it.

avatar image TPAKC Mar 30 '17 at 01:10 PM

My nick name in discrod - WhoreCraft

avatar image Furinyx Mar 30 '17 at 01:12 PM

What about the "#" numbers after it? You can find them below your name in the bottom-left corner.

avatar image TPAKC Mar 30 '17 at 01:22 PM

Whorecraft #3169

avatar image Furinyx Mar 30 '17 at 01:24 PM

Your friend settings under Privacy and Safety are not set to Everyone so it won't let me add you.

avatar image TPAKC Mar 30 '17 at 02:03 PM

Furinyx THANK YOU!!!!!!!!!! MY PROJECT NOW WORK! You best programmer! THANK THANK THANK YOU!

(comments are locked)
10|2000 characters needed characters left

As the error states at the end (I know, they can get pretty gross to read with long paths in them), you are using backslashes instead of forward slashes on a #include. You use forward slashes '/' for paths in #includes.

Go into the CharacterAI.cpp source file in your project and change the following:

#include "BehaviorTree\BehaviorTree.h"

to:

#include "BehaviorTree/BehaviorTree.h"

more ▼

answered Mar 29 '17 at 01:28 PM

avatar image

Furinyx
214 7 11 23

avatar image TPAKC Mar 29 '17 at 01:49 PM

I opened the file CharacterAI.cpp and cleared all the information. But the problem did not dare. Help me please!

avatar image Furinyx Mar 29 '17 at 02:21 PM

Can you post all of your errors you are getting now? The error you are getting in your shared video means there are errors in your code and the error you posted in your original post shows at least one of the culprits.

When you attempted to switch to another version it has to rebuild some dlls and successfully compile the source, if you have errors this will not work.

avatar image TPAKC Mar 29 '17 at 02:58 PM
avatar image Furinyx Mar 30 '17 at 12:47 AM

Sorry for the delay, had to sleep. You still have a camera utility class and game mode class in there after that second video which could be causing the compile error. It is still stopping on an error related to your project files; if you try to build via Visual Studio you can easily see the errors show in the Output window (I need to know what errors it is saying to be able to tell you what is still causing it to fail to compile).

avatar image TPAKC Mar 29 '17 at 06:32 PM

I'm delete Visual Studio and install now, but my problem not solved. Need help! Please!

avatar image Furinyx Mar 30 '17 at 12:48 AM

It won't be Visual Studio causing the error, it's almost unheard of for Visual Studio to be the cause. See my response I just made above.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question