x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

[Gear VR] Monoscopic Far Field renderer crashes

Since I finally got 4.15.1 up and running with FMOD and my project seems to work as expected after upgrading to 4.15.1, I decided to give monoscopic renderer a spin.

Sure enough right after level was loaded (streamed), the app crashed. Here is logcat:

https://drive.google.com/open?id=0BwE6dxM0O2PsVHhlUmZUbjFnYlk

Galaxy S6 Android 6.0.1 Exynos / Mali

I reported this to Oculus and they said it's due to CaptureSceneToScratchCubemap being called. I have Reflection Capture sphere in my scene as I need it to achieve better lighting for Sky Light. All lights are static / baked. And it shouldn't really matter because what if I want to use reflection capture for reflections and whatnot?!

Thanks beforehand

Product Version: UE 4.15
Tags:
more ▼

asked Mar 29 '17 at 02:26 PM in Bug Reports

avatar image

motorsep
378 39 48 66

avatar image AndrewHurley Mar 29 '17 at 03:11 PM

Hey motorsep,

As per usual when reporting a crash bug, I need a way to reproduce this issue on my end in a new blank project in order to report this as a bug.

Using reflection captures is useful in VR so do not worry about that as much. I need a minimal test case, without FMOD plugin etc. so I can report this issue internally.

Thanks,

Andrew H.

avatar image motorsep Mar 30 '17 at 01:12 AM

Alright, I made basic project (I have basic Gear VR template I used for all "blank project" tests) and it worked (didn't crash).

Apparently it's not reflection capture that causes the crash.

I have stereo layers, streaming levels, animation, particles, etc. in my project. So the only thing I can do at this point is upload my project and share download link with you or anyone else from Epic, privately.

avatar image AndrewHurley Mar 31 '17 at 04:34 PM

It falls on the user to narrow down a repro case in a blank or minimal project to showcase the issue. It is not our responsibility to take user's projects and figure out where and/or how the issue being described is occurring. We can offer suggestions or tips based on the evidence presented, but we simply do not have the resources or bandwidth to be able to test every users project and determine where the bug is occurring.

This does not mean we will not help, just that when writing a bug report, we need to provide a very minimal test case for our engineers to quickly identify the issue without having to sift through a number of content or irrelevant variables which could misdirect them to looking at something unrelated. Let me know if you have further questions.

Thanks,

Andrew Hurley

avatar image motorsep Mar 31 '17 at 05:10 PM

Yeah, I get that. I am just not sure how I can figure out the crash like this with UE4 when it crashes on the device and not in PIE.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

To get logs from your Android device:

  • Attach your phone to the computer

  • Go here: C:\NVPACK\android-sdk-windows\tools

  • Open up Monitor.bat

  • Launch the program and save the logs

If you cannot get Monitor.bat to open, please go to:

  • C:\NVPACK\android-sdk-windows\tools\lib\monitor-x86

  • Open up Monitor.exe

  • Follow the instructions above

Make sure that you highlight all of the logs, because they do not save unless they're highlighted.

Hopefully that sets you on the right path to identifying the issue.

Cheers,

Andrew Hurley

more ▼

answered Mar 31 '17 at 07:41 PM

avatar image motorsep Apr 01 '17 at 03:33 AM

I think I got it, but not really seeing anything useful (not sure what I need to look for, besides "crash"). PM'ed you on the UE4 forums with the link to the log file. Thanks.

avatar image motorsep Apr 05 '17 at 04:05 AM

Well, I ran monior.bat after I ran blank project (the one that doesn't crash) and I had exact same errors (and more) as with the project that crashes. So none of those contribute to the crash.

avatar image AndrewHurley Apr 05 '17 at 02:10 PM

Run a diff checker between the two logs to catch any outstanding differences that might exist. Then use that as a basis to find and determine where the project could be failing.

Thanks,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question