x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaged game crashes (4.13.2)

Hi guys,

I've been experiencing the following problem for a few weeks now, and finally decided to get some help from you to fix it. And of course I don't know everything I see in the logs, so maybe you do :P

First off, I've played the (99.99% BP-only) game without any problems in editor and standalone mode, even packaging seems fine now:
(Development Win64)
https://www.zerobin.net/?79da726b58d7a021#2aaEM77awOGcodVeDBb9GafRF9aDUWbAYKieyjMLSTU=
(Output Log of only the packaging (in entirety))

There are a couple of warnings, as you can see, but they don't seem to be critical.

When I try to execute the packaged .exe, the screen remains black and soon after, the game crashes. This is the log of it:

https://pastebin.com/fQSsF67U
(Log file after one failed attempt to start the .exe)
https://mega.nz/#!Cd0g0aTK!hS6Nq6EWTOqiyhB0iHZ7naEyVWwggxeZ0hUKtWyjdgc
(UE4Minidump from the same moment)

Measures I've taken so far:
1. Migrated important stuff to an empty project - set it up - packaged = same error ("Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x00000110")
2. deleted any intermediate stuff, staged builds, etc - re-compiled via VS2013 - packaged = same error ("..")
3. tried to fix several of the warnings in packaging by deleting assets that are no longer, but have been before, used - packaged = same error ("..")
4. disabling not-too-important plugins - restarted - packaged = same error ("..")
5. disabled read-only mode (why is it there?) for several of the packaged files, switched through compatibility modes and ran as admin = same error ("..")

  • I cannot reproduce this problem with a new, "empty" project.

  • I use plugins; all of them have never caused any problem before and most MUST remain in the project (lots of references).

I would be glad for any help with this - I've given up xD

Cheers, Abaris

Product Version: UE 4.13
Tags:
more ▼

asked Mar 29 '17 at 07:25 PM in Packaging & Deployment

avatar image

Abaris919
34 3 6 31

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey,
I did the only other thing remaining I could think of, namely trying to convert the project from 4.13.2 to 4.15.1.
I opened 4.15.1 then imported a COPY of the project in it.
All that was left to do, was updating the plugin files to 4.15 - which I was able to do for almost every plugin.
Since then, I've cleaned up assets and compiled anew.

Voilà - packaging and running works fine! Although I still have no idea what caused the problem, this (stressful) workaround worked fine =)

Cheers, Abaris

more ▼

answered Mar 30 '17 at 11:41 AM

avatar image

Abaris919
34 3 6 31

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question