x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.15.1 eventdispatcher not binding?!

Hi Guys,

Just migrated a project from 4.12.5 to 4.15.1, now I have blueprint A it has several event dispatchers (example: EVENT1). On the levelblueprint I take te reference to blueprint A and bind the EVENT1 to a customevent (CUSTOM1). But the custom event CUSTOM1 never runs, like the binding is not working. I'm sure the delegate for the event dispatcher is called from blueprint A (Call EVENT1).

Any idea's?

In 4.12.5 it's working fine, and I have no compiling errors. Also when I pull a string out of reference A the bind function for EVENT1 is listed.

Thanks,

B.

Product Version: UE 4.15
Tags:
more ▼

asked Mar 29 '17 at 08:44 PM in Bug Reports

avatar image

UninvitedB
26 2 3 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello UninvitedB,

Is it possible that this is a conversion issue? Have you tried recreating this event dispatcher to see if it works correctly? Also, when converting a project, doing so across multiple versions at once is not advised, as it can cause many problems such as this. If you can, I would suggest converting one version at a time and fixing errors as you go.

more ▼

answered Apr 04 '17 at 06:56 PM

avatar image UninvitedB Apr 11 '17 at 03:01 PM

Thanks for your reply, I will try to recreate it tomorrow. Maybe then I can fix the problem. It only is just a hell of a job to do for the entire project, but if it's the only way I have to.

Maybe other people experienced the same issues, I will post the result.

avatar image UninvitedB Apr 12 '17 at 08:07 PM

Wel...... the problem was:

-On the levelblueprint I spawn a actor (A)

-Actor (A) contains an eventdispatcher

-Then I bind an event to the dispatcher message at the levelblueprint

-The event was not called

This happend because I used on blueprint(A) "Event begin start" to call the eventdispatcher, so the event on the levelblueprint was not yet binded but allready called.

When i just wait 1 sec on blueprint (A) the event is binded on the levelblueprint and then called correctly.

Looks like the way of execution of the engine has changed, maybe it's faster then in the versions before.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question