x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Can't run my server

I packaged my game and tried to run the server and I get error messages and the application crashes.

The log: link text

Product Version: UE Github Master branch
Tags:
more ▼

asked Mar 30 '17 at 08:00 AM in Packaging & Deployment

avatar image

Althaen
166 13 18 32

avatar image Doug E ♦♦ STAFF Mar 30 '17 at 02:07 PM

Hey Althaen-

Does the crash occur when testing dedicated server inside the editor or only crash the packaged server? You can test this by checking the box for "Run Dedicated Server" in the dropdown list next to the Play button. If the crash doesn't occur in the editor, does the crash occur if you packaged a dedicated server of a new project?

avatar image Althaen Apr 05 '17 at 03:09 AM

I tried on a new project but I can't even get that to package for a different reason. It only crashes on the packaged server.

avatar image Doug E ♦♦ STAFF Apr 05 '17 at 01:34 PM

Looking at the logs provided, it seems to be failing when checking for a node added to a graph. This sounds to me like the server is trying to access something that is either client only or trying to reference something that hasn't been set.

Also, I noticed that you marked your post that you're using the master branch. Are you able to copy the project to a different engine version (such as the release branch) and package again?

avatar image Althaen Apr 08 '17 at 04:36 AM

That was my mistake I'm actually using the release branch.

avatar image Althaen Apr 08 '17 at 04:52 AM

I attempted to run the server exe in the unpacked project and I get this error: I think it may be connected?

alt text

avatar image Doug E ♦♦ STAFF Apr 10 '17 at 07:20 PM

What happens when you use "Run Dedicated Server" from within the editor? Can you provide the setup steps for your project? I have not been able to reproduce the behavior you've described on my end and want to ensure I'm following the same setup you're using.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Althaen-

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Cheers

Doug Wilson

more ▼

answered Apr 18 '17 at 04:02 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question