x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Begin Play Event Not Firing

Hello everyone!

I have not been able to get the Begin Play Events to fire in either my Level Blueprint nor my Gamemode (both of which are set as my defaults in my settings). The Gamemode is set as the Level's world settings. To describe it a bit more my level is just an empty level with nothing in it and when trying to set a breakpoint or any text prints in the Begin Play event neither work. I have tried playing it in the editor and as a packaged game neither worked. I have tried other projects and they seem to be functioning correctly. I'm trying to implement the online subsystem Steamworks and believe I have set everything for that up correctly.

I'm using 4.14.3

Thank you,

Das Joe

Product Version: UE 4.14
Tags:
more ▼

asked Mar 31 '17 at 03:09 AM in Using UE4

avatar image

Averagejoe
28 2 6 9

avatar image IGorilla Mar 31 '17 at 04:15 AM

Could you show a screenshot of your blueprint?

avatar image Averagejoe Mar 31 '17 at 01:54 PM

The same exact nodes are in both the level blueprint (shown here) and the gamemode.

alt text

screnshot.png (225.9 kB)
avatar image IGorilla Mar 31 '17 at 02:53 PM

I don't see any problems, maybe someone else can help?

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first

What's Up Averagejoe,

I hope everything is going well! So I am going to do my best to understand whats going on, and stepping through the problem usually helps me. So have you tried loading your Level without the GameMode you created. If you go into your World Settings, and override the GameMode to the default GameMode. See if your Event BeginPlay fires.

alt text

Peace,

Peter L. Newton

more ▼

answered Mar 31 '17 at 03:07 PM

avatar image

PeterLNewton
2.1k 75 36 110

avatar image PeterLNewton Mar 31 '17 at 03:11 PM

Also an additional note. Are you using Level Streaming?

avatar image Averagejoe Mar 31 '17 at 06:19 PM

Hello Peter,

So it seems that when using the default Gamemode or creating a new one works! Though my current Gamemode I'm using has nothing in it so I don't know what is wrong with it that would cause it to have problems like this. For now I'm just going to make a new and go from there.

Thank you,

Das Joe

EDIT: I think this might have been from a redirect error??

avatar image rz1974 Oct 23 '17 at 06:07 AM

Hi Averagejoe,

I have the same issue, and thanks for your workaround. I am using 4.17.2

(comments are locked)
10|2000 characters needed characters left
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question