x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

FileAccess Errors Windows 10/4.15

So, no idea what is going on. I originally thought I was only having problems updating my projects from 4.14.3 to 4.15.1, so I was going to just start from scratch in 4.15.1. Well, guess what? I can't. This does not happen in previous versions. Only 4.15. Blank Code projects work just fine. I can add another C++ class just fine. I tried to verify my install, it took a little bit, it downloaded some stuff, nothing changed.

Every time I try to create a C++ class in a blank Blueprint project I get a pop-up saying, it was created but could not be compiled and then this error msg in output log, which is also the same message that occurs when trying to rebuild/regenerate project:

 Running C:/Program Files/Epic Games/UE_4.15/Engine/Binaries/DotNET/UnrealBuildTool.exe  -projectfiles -project="H:/Hello/Test/Test.uproject" -game -rocket -progress
 Discovering modules, targets and source code for project...
 ERROR: System.UnauthorizedAccessException: Access to the path 'C:\Program Files\Epic Games\UE_4.15\Engine\Intermediate\ProjectFiles\Timestamp' is denied.
    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
    at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize)
    at System.IO.File.Create(String path)
    at UnrealBuildTool.UnrealBuildTool.RunUBT(String[] Arguments, FileReference ProjectFile)


This is kind of annoying.

Repro steps: Just watch video please: https://youtu.be/UGx3wFCKSsI

  1. 4.15 Blank Blueprint Project

  2. Add C++ Class

  3. Get Rekt

Product Version: UE 4.15
Tags:
more ▼

asked Mar 31 '17 at 03:34 AM in Bug Reports

avatar image

VictorBurgos
2.4k 61 27 113

avatar image VictorBurgos Apr 04 '17 at 08:43 PM

Don't let this sucker get away.

avatar image Tim C ♦♦ STAFF Apr 25 '17 at 02:51 PM

Hi Victor,

Sorry for the delay in responding to this post. I followed the steps that you used in your video, but my test project compiled fine for me when I added a code class to the Blueprint project.

If you haven't already tried what gundz suggested, could you try the Verify option for your Engine installation first and see if that helps?

Tim

avatar image VictorBurgos Apr 25 '17 at 03:15 PM

Hey Tim, I know you are all busy. At least you made it on here. Yeah, I tried to verify (posted that in my OP), then reinstalled 4.15 completely, no go. If I have to actually uninstall all versions and reinstall everything from scratch, that's just not going to be happening anytime soon.

But it's strange that the error is occurring anyway, and it's not just an isolated problem of mine. But since only gundz posted, maybe it's not as wide-spread as I figured it would be.

avatar image Tim C ♦♦ STAFF May 12 '17 at 03:07 PM

Hi Victor,

Just wanted to check in on this issue again to see if it is still giving you trouble. I still have not been able to reproduce it myself. Do you still see this happening in the 4.16 Preview?

Tim

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi I Had the same issue, was able to fix it with a complete uninstall/reinstall of Unreal Engine and the Launcher.

Hope it help.

more ▼

answered Apr 04 '17 at 09:08 PM

avatar image

gundz
32 4 7 9

avatar image VictorBurgos Apr 04 '17 at 09:16 PM

It may help, I'll give it a try later, not really a big deal for me since I can just create a code project, but it will be a big deal for others trying to start a BP project and then add C++ code to it.

The root cause needs to be investigated so it doesn't happen in future versions if this is just an issue with launcher/install.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question