x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Missing 'Generate Visual Studio Project Files' in context menu

Hi,

I'm having issues with getting the 'Generate Visual Studio Project Files' to appear and can't compile my project.

I know there are a few posts on this but I'm sure I have gone through them all and tried all the various solutions several times.

I've installed both UE 4.15 & UE 4.12. I've tried my hand at several solutions (this post http://www.davidmoore.info/blog/2014/09/05/fix-the-missing-right-click-menu-for-unreal-engine-projects-uproject/) setting the default app (https://answers.unrealengine.com/questions/450381/generate-visual-studio-project-files-didnt-show-up.html) and other suggestions but I have had no luck.

If I open my Visual Studio project I can see that all the Build commands are pointing to incorrect Unreal location. The project has been copied from another PC which has UE4 in different location.

I cannot find the 'UnrealVersionSelector' in the Binaries 64 folder as some have suggested. I have used the Epic Games launcher to install the different versions of Unreal. As I have said, uninstalling all traces of Epic Games and re-installing hasn't helped. Tried installing the Launcher in different location than x86 but hasn't helped.

If I use the bat file has shown here 'http://www.davidmoore.info/blog/2014/09/05/fix-the-missing-right-click-menu-for-unreal-engine-projects-uproject/' I get an 'Can't find the Unreal Engine' error although both 4.15 & 4.12 are installed.

I have also downloaded the source from .git as some have suggested as tried to use the 'UnrealVersionSelector-Win64-Shipping' but get an 'Invalid Command Line' error. I have tried the various Setup.bat shipped with the source.

As you can see I've been trying for awhile to fix this issue had very frustrated to not have my project building in VS. Help on this and any other ideas on what to try would be very, very helpful.

Thank you!

Product Version: UE 4.15
Tags:
more ▼

asked Apr 01 '17 at 10:26 PM in Installation & Setup

avatar image

privateeyejake
31 1 6 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

OK thank you to @MadSystem for pointing me in the right direction. Checking out this thread: https://forums.unrealengine.com/showthread.php?109862-Association-uproject-unreal-are-broken

As suggested in the bottom of the thread I manually copied the 'UnrealVersionSelector.exe' from 'C:\Program Files (x86)\Epic Games\Launcher\Engine\Binaries\Win64' to the engine binaries folder: C:\Program Files\Epic Games\UE_4.15\Engine\Binaries\Win64'

Then set the uproject file to associate with the newly placed 'UnrealVersionSelector'. The right-click menu came back and I can finally rebuild Visual Studio project files. Yay!

Thanks!

more ▼

answered Apr 02 '17 at 12:22 PM

avatar image

privateeyejake
31 1 6 6

avatar image Axelven Apr 03 '18 at 11:20 PM

Thanks man, it works wonderfully.

avatar image incfour Dec 11 '18 at 06:01 AM

thx good!!

avatar image Simon D. Levy Jan 27 '19 at 10:48 AM

Brilliant solution, worked for me -- THANK YOU!

avatar image Jason.Brown1 Mar 14 '19 at 05:18 AM

Thanks for the solution. Worked here. Thanks!

avatar image barisalhan 5 days ago

Thanks for the solution!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Im having a similar issue. I did install Windows 10 3 days and after that I also reinstalled the epic game laucher. Since then I have no right-click-context menu for .uproject files anymore.

more ▼

answered Apr 02 '17 at 11:14 AM

avatar image

MadSystem
1 1 2

avatar image privateeyejake Apr 02 '17 at 11:24 AM

Are you able to compile and launch your project still? I don't think my project is compiling due to incorrect Visual Studio settings so I'm kinda stuck.

Have you tried some of the fixes dotted around such as the links I posted?

avatar image MadSystem Apr 02 '17 at 11:48 AM

I can compile newly created projects.

avatar image MadSystem Apr 02 '17 at 12:08 PM
avatar image privateeyejake Apr 02 '17 at 12:22 PM

Thank you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I did not copy any files.

I just set the file association of the ".uproject" file to "C:\Program Files (x86)\Epic Games\Launcher\Engine\Binaries\Win64\UnrealVersionSelector.exe" by following these steps:

  1. right-click the .uproject file

  2. click "open with..."

  3. click "choose another app"

  4. click "more apps"

  5. click "look for another app"

  6. browse to "C:\Program Files (x86)\Epic Games\Launcher\Engine\Binaries\Win64\"

  7. select "UnrealVersionSelector.exe"

  8. click "open"

more ▼

answered Mar 19 '18 at 09:15 AM

avatar image

Constantin Suman
44 2 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question