x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Game crash while loading level

Hello,

We are building a VR game for HTC Vive and the game randomly crash just after a level load (a first frame of the level is rendered in the headset). Here is logs and various files.

screenshot

Thanks !

Product Version: UE 4.15
Tags:
screenshoot.png (1.2 MB)
ue4_crash.zip (52.6 kB)
more ▼

asked Apr 03 '17 at 08:09 AM in Bug Reports

avatar image

gobanos
1 1 3

avatar image Rudy Q ♦♦ STAFF Apr 03 '17 at 02:27 PM

Hello gobanos,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any settings/blueprints that may be involved with this issue?

  4. Could you provide your complete callstack that is given via the crash reporter?

avatar image gobanos Apr 04 '17 at 01:26 PM

Hi,

I tried to reproduce this with VR startup content, but I can't. The crash reporter won't launch, I just got the "classic" crash window.

On my dev computer I manage to launch the debugger, so I have a (little) more detailed error : alt text

But without the symbols, it's meaningless...

I join a screen where you can see the stack : alt text

And a other with the method to open a new level : alt text

Thanks for your time !

exception.png (8.6 kB)
exception-full.png (111.9 kB)
load-level.png (107.5 kB)
avatar image Rudy Q ♦♦ STAFF Apr 11 '17 at 06:56 PM

I ran more tests on our end with the information provided. However, I have not been able to reproduce this issue on our end. Could you provide a stripped down copy of the project so that I could take a closer look?

avatar image Rudy Q ♦♦ STAFF Apr 17 '17 at 07:39 PM

Hello gobanos,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Thanks,

avatar image gobanos Apr 18 '17 at 04:09 PM

Hello Rudy,

I managed to get a few more info, seems to be the assert "check(IsInRenderingThread());" in Engine/Source/Runtime/MediaAssets/Private/Misc/MediaTextureResource.cpp:564 who fail.

I have a dump and a pdb file, but they are quite heavy (2.6Go and 83Mo respectively), is there a way to send them to you ?

Thanks !

avatar image Rudy Q ♦♦ STAFF Apr 18 '17 at 07:02 PM

Could you provide the project via google drive or drop box so that I can take a closer look?

avatar image gobanos Apr 19 '17 at 08:47 AM

https://drive.google.com/open?id=0B1H0OjASAwKqQWc2Z2dRWHlwM2c I can't send you more than that, I hope that would be enough.

IMO the assert who fail is in FMediaTextureResource::ConvertResource(struct FMediaTextureResource::FResource const &) stack, address 0x00007FF6344BD70B: call IsInRenderingThread.

Thanks !

avatar image Rudy Q ♦♦ STAFF Apr 27 '17 at 08:07 PM

I have been unable to reproduce this issue with the information provided. Could you check to see if this issue still occurs in the 4.16 preview?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Thanks Rudy,

I couldn't reproduce this issue with 4.16 preview, is release date already planned ?

more ▼

answered Apr 28 '17 at 02:09 PM

avatar image

gobanos
1 1 3

avatar image Rudy Q ♦♦ STAFF Apr 28 '17 at 02:33 PM

We do not have a release date at this time for the 4.16 release. I am happy to hear that the issue is no longer occurring the latest version. If the issue returns for the latest version feel free to reopen this issue with a reply containing any additional information you may have and I will be happy to investigate further.

Make it a great day

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question