x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

ForLoop not working

I am using a forloop that has its index connected to a macro I made. The macro then links to a print string. When I run the level, all the prints are based on the last index of the forloop alone. The first index and so on don't seem to be effecting the output of the macro Anything I'm doing wrong?

Product Version: UE 4.15
Tags:
more ▼

asked Apr 03 '17 at 10:08 AM in Using UE4

avatar image

vikhyatvd7
9 5 8 11

avatar image Shivam.Dhoot Apr 03 '17 at 10:22 AM

Provide a snapshot of your blueprint, for loop part and macro.

avatar image vikhyatvd7 Apr 03 '17 at 10:57 AM

Here it is: alt text

The index is connected to fixture number and is passed as an argument in an html request.

capture.png (50.2 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Its okay, got it to work how I wanted by following this link: https://answers.unrealengine.com/questions/50642/question-how-do-i-add-a-delay-to-each-iteration-of.html Thanks for the help tho!

more ▼

answered Apr 04 '17 at 09:12 AM

avatar image

vikhyatvd7
9 5 8 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I think the issue is with the JSONFixtures because when I try to use a for loop it works fine.

alt text

more ▼

answered Apr 03 '17 at 11:47 AM

avatar image

MrGoatsy
604 35 27 45

avatar image vikhyatvd7 Apr 03 '17 at 12:39 PM

Well, I don't exactly think so because if I link another JsonFixture and Print String after the orginal two without any loop, they both respond according to their indices as intended.

avatar image MrGoatsy Apr 03 '17 at 02:23 PM

Can do do a print string after the loop body and before the JSONFixtures?

avatar image vikhyatvd7 Apr 03 '17 at 02:41 PM

I don't see the point of that because I print the data that is output from JSONFixtures.

avatar image MrGoatsy Apr 03 '17 at 03:33 PM

Just do it to test out whether the for loop is working or not.

avatar image vikhyatvd7 Apr 03 '17 at 04:21 PM

Ya, the ForLoop works fine without the macro

avatar image MrGoatsy Apr 03 '17 at 04:23 PM

Please double click the macro and show us that.

avatar image vikhyatvd7 Apr 03 '17 at 04:45 PM

It uses nodes from the Varest plugin. alt text

alt text

sorry for the mess. I'm beginning to think it's because of the download image node which is a delay of sorts

capture.png (154.2 kB)
capture1.png (140.2 kB)
avatar image MrGoatsy Apr 03 '17 at 05:04 PM

Please put a unique print string after each executable node to see where it stops working.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question